Lookups are broken on Multiday XBL views of calendar

RESOLVED WORKSFORME

Status

Testing Graveyard
Mozmill
--
major
RESOLVED WORKSFORME
9 years ago
2 years ago

People

(Reporter: cmtalbert, Unassigned)

Tracking

Details

(Whiteboard: [mozmill-1.1])

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 357213 [details]
Picture of the DOM tree

If you attempt to do a lookup on an event box in the day or week view of the calendar, the lookup code breaks.  However the Mozmill inspector says that the lookup is validated but when you attempt to use the lookup, it doesn't work.

It fails at the /{"flex":"1"}/ node, which corresponds to a stack about half way to our target the box with the anonid of "eventbox".

You can see various attempts at trying to make this work in the test I'm attaching.  They are all commented out,and the original output of the inspector is marked.  

In the attached picture, you can see the stack, and the highlighted element is the node we're after.

Repo:
Install trunk Shredder
Install Mozmill
Install lightning
Uncomment the DAY/WEEK lines in the test and run it.
(Reporter)

Comment 1

9 years ago
Created attachment 357214 [details]
the test
(Reporter)

Updated

9 years ago
Whiteboard: [mozmill-1.1]
(Reporter)

Comment 2

9 years ago
This is currently working for me now.  Not sure what changed to help it out.

--> WFM
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

2 years ago
Product: Testing → Testing Graveyard
You need to log in before you can comment on or make changes to this bug.