Insane visual lag and high CPU usage when smooth scrolling with position:fixed elements

RESOLVED DUPLICATE of bug 372039

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 372039
9 years ago
9 years ago

People

(Reporter: Robert, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

When smooth scrolling in a page that has a large element that has the CSS position:fixed property, the CPU usage becomes insanely high, almost always 100% for the core in use. Usually the visual lag is visible as well. I can't say this next thing with certainty, but I believe that if a page has many elements, such as a big table, the visual lag becomes worse.

I've supplied a slashdot article as an example, because the comments bar becomes fixed when you scroll down non-members and members who didn't change that setting.

Reproducible: Always

Steps to Reproduce:
1. Visit a site with a large element that has the CSS position:fixed property.
2. Make sure smooth scrolling is enabled
3. Watch the CPU usage and/or visual lag when scrolling (quickly).
Actual Results:  
Visual lag

Expected Results:  
Scrolling as if everything was dandy.

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 372039
You need to log in before you can comment on or make changes to this bug.