Assertion failed: "Unknown branch type in nPatchBranch": 0 - js1_8_1/trace/trace-test.js - browser only

VERIFIED WORKSFORME

Status

()

Core
JavaScript Engine
VERIFIED WORKSFORME
9 years ago
9 years ago

People

(Reporter: bc, Assigned: gal)

Tracking

({assertion, regression, testcase})

1.9.1 Branch
x86
All
assertion, regression, testcase
Points:
---
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
js1_8_1/trace/trace-test.js asserts Assertion failed: "Unknown branch type in nPatchBranch": 0
on 1.9.1 (mozilla-1.9.1) browser only. I'm looking for the regression range.
Flags: in-testsuite+
Flags: in-litmus-
(Assignee)

Updated

9 years ago
Assignee: general → gal
(Assignee)

Comment 1

9 years ago
WFM on TM tip.
(Reporter)

Comment 2

9 years ago
regression changeset: 22711:e24b6e3ed5a4 user: Igor Bukanov <igor@mir2.org> date: Thu Dec 25 01:23:38 2008 +0100 summary: bug 471044 - fixing upgvar detection for for-in loop. r=mrbkap
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/e24b6e3ed5a4
Blocks: 471044
(Reporter)

Comment 3

9 years ago
this works for me now.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 4

9 years ago
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.