Changing a recurring/repeating event to non-recurring doesn't work

VERIFIED FIXED in 1.0b1

Status

defect
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: brinel, Unassigned)

Tracking

Lightning 0.9
1.0b1

Details

(Whiteboard: [depends-google-issue])

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Thunderbird version 2.0.0.19 (20081209) Lightening 0.9 (build 2008091719) GDATA provider 0.5.1

Creating a recurring event from Lightening or Google both work as expected.

Changing the event to non-recurring from Google works as expected (changes sync to Lightening).

Changing the event to non-recurring from Lightening fails with MODIFICATION_FAILED when talking to Google Calendar.

Reproducible: Always

Steps to Reproduce:
1. Create a repeating event
2. Edit event in Lightening, set to non-repeating, hit Save.




From the Error Console:

General response failed: [Exception... "A request Error Occurred. Status Code: 400 Bad Request Body: Recurring event must have recurrence rule"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Brian/Application%20Data/Thunderbird/Profiles/vgktmv21.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/components/calGoogleCalendarModule.js -> file:///C:/Documents%20and%20Settings/Brian/Application%20Data/Thunderbird/Profiles/vgktmv21.default/extensions/%7Ba62ef8ec-5fdc-40c2-873c-223b8a6925cc%7D/js/calGoogleCalendar.js :: cGC_general_response :: line 970"  data: no]

Warning: There has been an error reading data for calendar: Google GDATA.  However, this error is believed to be minor, so the program will attempt to continue. Error code: 0x80004005. Description: A request Error Occurred. Status Code: 400 Bad Request Body: Recurring event must have recurrence rule

Error: An error occurred when writing to the calendar Google GDATA! Error code: MODIFICATION_FAILED. Description: 
Source File: file:///C:/Documents%20and%20Settings/Brian/Application%20Data/Thunderbird/Profiles/vgktmv21.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calItemModule.js -> file:///C:/Documents%20and%20Settings/Brian/Application%20Data/Thunderbird/Profiles/vgktmv21.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/js/calCalendarManager.js
Line: 952
(Reporter)

Updated

10 years ago
Version: unspecified → Lightning 0.9
This is a server bug, see:

http://code.google.com/p/gdata-issues/issues/detail?id=296

Please test if this works with Google's CalDAV, see: 

http://www.google.com/support/calendar/bin/answer.py?answer=99358#sunbird
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [depends-google-issue]
(Reporter)

Comment 2

10 years ago
This works properly via CalDAV.

Currently, I'm staying with GDATA because CalDAV seems to have an issue setting reminders. I haven't investigated it yet, but this problem with GDATA was less frequent/annoying than the reminder issue with CalDAV.
Google issue 296 was marked FIXED.

reminders: Please use the latest 1.0pre, this should allow reminders to work via Google CalDAV.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
OS: Windows XP → All
Hardware: x86 → All
(Reporter)

Comment 4

10 years ago
Confirmed fixed in 0.9. Thanks!
Status: RESOLVED → VERIFIED
Target Milestone: --- → 1.0
These bugs are likely targeted at Lightning 1.0b1, not Lightning 1.0. If this change was done in error, please adjust the target milestone to its correct value. To filter on this bugspam, you can use "lightning-10-target-move".
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.