Address Bar Scrolling Failure.

VERIFIED WONTFIX

Status

()

--
major
VERIFIED WONTFIX
10 years ago
10 years ago

People

(Reporter: ninglorithiel, Unassigned)

Tracking

3.0 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

The address bar has an arrow that drops down a list of previously entered sites. In the past, this list has been fully scrollable.

Since upgrading to the latest update, I have found this function no longer exists; the browser limits the list to the last 12 sites viewed, even though there is a week's worth of sites in my search history. They also appear in no particular order (ie, not in the order visited). 

Thinking it may be a conflict with an older theme, I changed my theme to the default of the most current version of Firefox. This did not alter the situation, apart from making all the browser's buttons look exceedingly ugly.




Reproducible: Always

Steps to Reproduce:
1.Open Firefox.
2.Visit a few websites.
3.Pull down the arrow on the navigation address bar. Observe the total lack of a scroll bar adjacent to said list.
4.Weep over the loss of critical functionality like every other internet junkie in the 'verse.
Actual Results:  
No scroll bar. Much swearing and weeping on the keyboard ensued.

Expected Results:  
An ability to scroll through the previous urls in the address bar drop menu.

I tested this on three themes: Firefox2 Reloaded, Default 3.0.5, and Classic Compact 3.0.9. This function failed on all three.

Computer was shutdown and rebooted; error in browser persisted.
(Reporter)

Updated

10 years ago
Version: unspecified → 3.0 Branch
The length is controlled by the preference browser.urlbar.maxRichResults, but it's always been set to 12.  The behavior is what is intended, and you can customize it by changing that preference.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
(Reporter)

Comment 2

10 years ago
I think you are not understanding the issue. There is no side scroll feature in the drop menu. There was in Firefox 2. Max results don't enter into it.

You also failed to explain where this preference setting may be found so that it may be customized.
You need to log in before you can comment on or make changes to this bug.