Closed Bug 474080 Opened 11 years ago Closed 11 years ago

Minefield crashes when a message in the Hotmail email list is dragged (seperate to other Hotmail bug). [@ 0x0][@ JS_TraceChildren ]

Categories

(Core :: JavaScript Engine, defect, critical)

1.9.0 Branch
All
Windows XP
defect
Not set
critical

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: onehundredandseventeen, Assigned: Waldo)

References

()

Details

(Keywords: crash)

Crash Data

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-AU; rv:1.9.2a1pre) Gecko/20090115 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-AU; rv:1.9.2a1pre) Gecko/20090115 Minefield/3.2a1pre

(Same as above) the Minefield browser crashes whenever one of the emails is dragged.

Reproducible: Always

Steps to Reproduce:
1. Login to Hotmail
2. Drag one of the messages (drag it anywhere)
Actual Results:  
Minefield froze and crashed.

Expected Results:  
The "1 message" should have followed my cursor and if I placed it above a folder it should have placed it into it.

I am using the default theme, the only add-on I have installed is the Java Quick Starter add-on. I did not receive any crash information when it crashed or started up again.
Same problem exists in Mozilla Firefox Beta 2, I used a new profile with no add-ons connected to it and the same problem still exists.
type about:crashes in the address bar and copy and paste the crash ids into this bug.
I can confirm this with Firefox 3.1 beta 2. It froze and crashed when you drag 1 of the message (in hotmail) to anywhere. 
User Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2. 



Crash id                                        dd/mm/yyyy      hr:min
d717ea6c-7371-487b-b365-59e642090111	        11/01/2009      23:25
afd76780-9b1e-4c98-a820-709772081216            17/12/2008	01:43
Signature	@0x0
UUID	d717ea6c-7371-487b-b365-59e642090111
Time	2009-01-11 07:23:03-08
Uptime	41919
Last Crash	2238033 seconds before submission
Product	Firefox
Version	3.0.5
Build ID	2008120122
Branch	1.9
OS	Windows NT
OS Version	5.1.2600 Service Pack 3
CPU	x86
CPU Info	GenuineIntel family 6 model 15 stepping 6
Crash Reason	EXCEPTION_ACCESS_VIOLATION
Crash Address	0x0
Comments	when visiting window live essitials website Firefox crashed.

there's no stack.

try safemode/disabling flash?
Keywords: crash
Summary: Minefield crashes when a message in the Hotmail email list is dragged (seperate to other Hotmail bug). → Minefield crashes when a message in the Hotmail email list is dragged (seperate to other Hotmail bug). [@ 0x0]
       Report ID            Date Submitted
7044dd79-667a-4203-b234-ea1f72081225   26/12/2008 10:37 AM
OK I've tried starting Firefox in -safe-mode and it does not crash, and Windows still tells me Firefox is responding, but Firefox itself stops responding to whatever I do.

Exiting Firefox also does not come up with "Window not Responding, End Now" box, it just exits. This is different to not in safe-mode but both ways still have the same bug.
[@ JS_TraceChildren ]
bp-7044dd79-667a-4203-b234-ea1f72081225
Signature: JS_TraceChildren

0	js3250.dll	JS_TraceChildren	js/src/jsgc.cpp:2365
1	js3250.dll	JS_CallTracer	js/src/jsgc.cpp:2642
2	js3250.dll	js_TraceObject	js/src/jsobj.cpp:5281
3	js3250.dll	JS_TraceChildren	js/src/jsgc.cpp:2366
4	js3250.dll	JS_CallTracer	js/src/jsgc.cpp:2642
5	js3250.dll	js_CallValueTracerIfGCThing	js/src/jsgc.cpp:2690
6	js3250.dll	gc_root_traversal	js/src/jsgc.cpp:2746
7	js3250.dll	JS_DHashTableEnumerate	js/src/jsdhash.cpp:724
8	js3250.dll	js_TraceRuntime	js/src/jsgc.cpp:3024
9	js3250.dll	js_GC	js/src/jsgc.cpp:3423
10	js3250.dll	JS_GC	js/src/jsapi.cpp:2487
11	xul.dll	nsXREDirProvider::DoShutdown	toolkit/xre/nsXREDirProvider.cpp:864
12	xul.dll	ScopedXPCOMStartup::~ScopedXPCOMStartup	toolkit/xre/nsAppRunner.cpp:946
13	xul.dll	XRE_main	toolkit/xre/nsAppRunner.cpp:3314
14	firefox.exe	wmain	toolkit/xre/nsWindowsWMain.cpp:87
15	firefox.exe	firefox.exe@0x2197	
16	kernel32.dll	kernel32.dll@0x17066
Assignee: nobody → general
Severity: normal → critical
Component: General → JavaScript Engine
Product: Firefox → Core
QA Contact: general → general
Summary: Minefield crashes when a message in the Hotmail email list is dragged (seperate to other Hotmail bug). [@ 0x0] → Minefield crashes when a message in the Hotmail email list is dragged (seperate to other Hotmail bug). [@ 0x0][@ JS_TraceChildren ]
Version: unspecified → 1.9.0 Branch
Seems to be resolved with #462428 Regression preventing Minefield from working with latest Hotmail upgrade.

Can anyone confirm this for me before status changed to Resolved?
It doesn't seem to be resolved.
I have WinXP SP3 and Firefox Built from http://hg.mozilla.org/releases/mozilla-1.9.1/rev/7c53d4f16308 :(
my addons (latest adblock plus)

When i drag a mail firefox hangs and takes more and more memory.

I think it should block beta 3 because many users have hotmail and would be disappointed when it doesn't work.
Flags: blocking1.9.1?
waldo, can you figure out if this is still happening?
Assignee: general → jwalden+bmo
Flags: blocking1.9.1? → blocking1.9.1+
Sure.  Sorry for the delay in responding, this got hidden by other bugmail I need to go through...
I tested it again and it seems to work correctly with

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090220 Minefield/3.2a1pre

Built from http://hg.mozilla.org/mozilla-central/rev/35d78a340566
Please reopen if you see this again.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → WORKSFORME
Crash Signature: [@ 0x0] [@ JS_TraceChildren ]
You need to log in before you can comment on or make changes to this bug.