Last Comment Bug 474086 - Remove the Guided Bug Entry Form out of the core Bugzilla code
: Remove the Guided Bug Entry Form out of the core Bugzilla code
Status: RESOLVED WONTFIX
:
Product: Bugzilla
Classification: Server Software
Component: Creating/Changing Bugs (show other bugs)
: 3.3
: All All
: -- normal (vote)
: ---
Assigned To: Max Kanat-Alexander
: default-qa
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-16 18:30 PST by Max Kanat-Alexander
Modified: 2009-01-20 08:57 PST (History)
6 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
v1 (23.32 KB, patch)
2009-01-16 18:37 PST, Max Kanat-Alexander
no flags Details | Diff | Review

Description Max Kanat-Alexander 2009-01-16 18:30:53 PST
We get lots of bugs about the guided form, even though it's just an example customized template. We could either move it to the example/ extension, or just remove it entirely. The thing about moving it to the example extension is that people might still report bugs about it, so I'm kind of thinking we should just get rid of it entirely or put it in contrib/.
Comment 1 Max Kanat-Alexander 2009-01-16 18:37:15 PST
Created attachment 357464 [details] [diff] [review]
v1

Okay, this just removes the guided form entirely and every reference to it. I don't think we really need it at all anymore, particularly since we're going to have a simplified bug entry form in Bugzilla 3.4.
Comment 2 Marc Schumann [:Wurblzap] 2009-01-17 01:01:39 PST
I'm in favour of removing the guided bug entry form in its current form, too. I think we shouldn't remove it entirely, though. The feature to be able to split up the comment textarea into several input fields needs to have an example. Documentation (we have some: http://www.bugzilla.org/docs/tip/en/html/cust-templates.html#template-specific) does not suffice imho. Having a simplified bug entry form (bug 376673) does not cover this.

Maybe it's better to strip it down *a lot* (drop duplicates table, drop most (all?) fields besides summary and component, drop most (all?) accompanying text, keep splitting comment into steps-to-reproduce and description) and move it to contrib.
Comment 3 Gervase Markham [:gerv] 2009-01-17 02:53:04 PST
Slightly surprised not to be CCed on this bug...

If we get bugs about the guided form, we should fix those bugs, because mozilla.org uses it. If you don't want to deal with them, that's no problem - pass them to me.

The guided form was included as an example of bug entry templates, and I've found it useful on occasion to point to it as such when doing support. Do you plan to replace it with an alternative example?
 
Gerv
Comment 4 Frédéric Buclin 2009-01-17 08:50:18 PST
(In reply to comment #3)
> If we get bugs about the guided form, we should fix those bugs, because
> mozilla.org uses it.

Because mozilla.org uses it? How does this justify to keep the template based on this single argument? Could we stop seeing Bugzilla as being bmo only?


Now, I think Wurblzap is right. Having a much lighter guided form would still make sense, but with all the bmo-specific logic going away. Also, I think it would be a good idea to keep the lighter guided form in extensions/example/template/.
Comment 5 Gervase Markham [:gerv] 2009-01-18 13:12:39 PST
The reason for keeping it and the reason for fixing bugs in it are separate, although they are related. 

We don't keep it just because mozilla.org uses it, we keep it because it's an example of bug entry templates.

We don't fix bugs in it as a priority because it's an example, but because mozilla.org uses it.

The two work together because mozilla.org gets the convenience (admittedly now reduced because of changes in SCM arrangements) of not having to maintain it separately, and the Bugzilla project gets a working and usable example of bug entry templates, and everyone is happy.

If you feel that e.g. the quality of the current implementation reflects badly on the Bugzilla project (for example), point me at the bugs you want fixed. If you feel it doesn't serve well as an example, explain how it could do so better.

Gerv
Comment 6 Max Kanat-Alexander 2009-01-18 17:12:06 PST
(In reply to comment #5)
> We don't keep it just because mozilla.org uses it, we keep it because it's an
> example of bug entry templates.

  That's not important enough. We could put it in contrib/ and not maintain it, for the same value. But it would actually be a BAD example, because it doesn't work.

> We don't fix bugs in it as a priority because it's an example, but because
> mozilla.org uses it.

  Actually, *we* don't fix bugs in it at all, and haven't for some time.

> If you feel that e.g. the quality of the current implementation reflects badly
> on the Bugzilla project (for example), point me at the bugs you want fixed.

  I moved them all to the mozilla.org product:

  http://tinyurl.com/7sc8e3

  However, nobody will review them, even if you post a patch, because we're working on other things. So if you want to maintain it separately from the Bugzilla tree and keep it around somewhere where people can see it as an example, that would be fine. Then you wouldn't need review, and everybody would be happy.
Comment 7 A. Shimono [:himorin] 2009-01-19 10:03:48 PST
I agree with Wurblzap, too.
But I don't think it's better to keep such old and un-maintained version of bug-entering form in "example". Admins can customize and add some new sections to the primary? bug-entering form, but I think they shouldn't refer older templates which may include the obsoleted variables.
Comment 8 Dave Miller [:justdave] (justdave@bugzilla.org) 2009-01-19 12:09:54 PST
It's always seemed to be well-maintained to me.  Gerv's been good about fixing bugs in it when people actually let him know the bug is there.  All this "it's not maintained" stuff is bogus.  If that's your excuse for removing it you're grasping at straws.

That said, as Gerv says, the new SCM arrangements make it much less of a hassle to maintain it separately.  Other than "being an example" I don't see any compelling reason to keep it in the upstream tree.  b.m.o's SCM is publicly accessible, so we could always link to it from the docs to point out the example.  It probably needs a more permanent hostname before we do that though.
Comment 9 Dave Miller [:justdave] (justdave@bugzilla.org) 2009-01-19 12:12:45 PST
The thing about having the example in the upstream tree is that the example would work with the version of Bugzilla you're looking at.  Linking to bmo's SCM would only get you versions that work on the versions of Bugzilla that bmo has had in that SCM (which is only 3.0 and 3.2 so far, and those are actually in different repos on the server - there's no version of it for the trunk for example)
Comment 10 Max Kanat-Alexander 2009-01-19 12:28:08 PST
(In reply to comment #9)
> The thing about having the example in the upstream tree is that the example
> would work with the version of Bugzilla you're looking at. 

  The example is currently completely bmo-specific. I don't think it has ever worked in the upstream tree.
Comment 11 Gervase Markham [:gerv] 2009-01-19 15:14:09 PST
Max: it works just fine, and always has. Visit:
https://landfill.bugzilla.org/bugzilla-tip/enter_bug.cgi?product=FoodReplicator&format=guided
to use it on the tip. I successfully filed bug (landfill) 7391. 

It's not "old" and it's not "unmaintained". If it needs a round of bug fixes, as I said, I'm happy to do them. But my experience above indicates that it works fine. It may need enhancements for mozilla.org-specific needs, which I should also do, but whether it needs those or not is unrelated to the question we are discussing.

I'll just go and triage that list of yours.

Gerv
Comment 12 Max Kanat-Alexander 2009-01-19 16:50:55 PST
Okay, if you're willing to maintain it, then that's fine. I actually wasn't even aware that it had a maintainer.
Comment 13 Frédéric Buclin 2009-01-20 08:57:33 PST
I still think bmo-specific code has nothing to do in the template.

Note You need to log in before you can comment on or make changes to this bug.