Closed Bug 474116 Opened 11 years ago Closed 11 years ago

Clean up deprecated GTK symbols

Categories

(Core :: Widget: Gtk, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: Swatinem, Assigned: Swatinem)

References

(Depends on 1 open bug)

Details

Attachments

(1 file, 2 obsolete files)

Attached patch clean up deprecated gtk symbols (obsolete) — Splinter Review
Make gecko future proof by cleaning up deprecated GTK functions which may be removed completely in some future version of gtk.
This is mostly gobject stuff and should be available in gtk 2.10.
The patch does not regress reftests or mochitests for me (although both of them do not run very reliably even without this patch)
It should be run through the tryserver in any case to make sure it works correctly.

BTW: are there automated tests for gtkmozembed?
Attachment #357489 - Flags: superreview?(roc)
Attachment #357489 - Flags: review?(roc)
Attachment #357489 - Flags: review?(benjamin)
-  // XXX work around until I can get pink to figure out why
-  // tooltips vanish if they show up right at the origin of the
-  // cursor.
-  root_y += 10;

So we're not doing this anymore. It sounds like that will break things, according to this comment. So either test it and make sure it doesn't break tooltips, or just take this change out of the patch, or do it in a way which gives us a y-offset.

The rest of the patch looks fine.
Tooltips work for me in Web Content and in TestGtkEmbed, however I'm not sure the code is hit at all.
Benjamin: As embedding module owner, can you help me get this code tested?
You can set a printf there to see if the code is hit at all.

If you're not sure what to do, I recommend just taking this change out of the patch.
I was trying to use gdb breakpoints.
Patch now without that change.
Attachment #357489 - Attachment is obsolete: true
Attachment #357644 - Flags: superreview?(roc)
Attachment #357644 - Flags: review?(roc)
Attachment #357644 - Flags: review?(benjamin)
Attachment #357489 - Flags: superreview?(roc)
Attachment #357489 - Flags: review?(roc)
Attachment #357489 - Flags: review?(benjamin)
Attachment #357644 - Flags: superreview?(roc)
Attachment #357644 - Flags: superreview+
Attachment #357644 - Flags: review?(roc)
Attachment #357644 - Flags: review+
Attachment #357644 - Flags: review?(benjamin) → review+
Comment on attachment 357644 [details] [diff] [review]
clean up deprecated gtk symbols, v2

r=me

I don't think we want this for 1.9.1
(In reply to comment #5)
> I don't think we want this for 1.9.1

Then lets get this into m-c (or tryserver first). Patch ready for hg import.
Attachment #357644 - Attachment is obsolete: true
Attachment #358012 - Flags: superreview+
Attachment #358012 - Flags: review+
Keywords: checkin-needed
Whiteboard: [checkin to tryserver first]
http://tinderbox.mozilla.org/showbuilds.cgi?tree=MozillaTry&maxdate=1232877753 certainly didn't object to it, though the unit test machines are more of a trial.
Whiteboard: [checkin to tryserver first]
Comment on attachment 358012 [details] [diff] [review]
patch for checkin
[Checkin: Comment 8]


http://hg.mozilla.org/mozilla-central/rev/ce7f39495675
Attachment #358012 - Attachment description: patch for checkin → patch for checkin [Checkin: Comment 8]
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Depends on: 476805
Blocks: 461277
Depends on: 486940
Duplicate of this bug: 575096
Duplicate of this bug: 575095
Depends on: 1354417
You need to log in before you can comment on or make changes to this bug.