Closed Bug 474214 Opened 13 years ago Closed 13 years ago

Multiple master password prompts on launch, regression

Categories

(Thunderbird :: Mail Window Front End, defect)

x86_64
Windows Vista
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 437635

People

(Reporter: mrthefter, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090108 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090117 Lightning/1.0pre Shredder/3.0b2pre

Previous to this version, this did not happen. Several nightly versions before this one, Thunderbird would not even execute the main window thread without having first dealt with the master password dialog, which would avoid this problem in the first place. In any case, this would be the preferred behavior, as with the new automatic IMAP local cache, emails can be easily accessed if the dialog was dismissed.
This problem will presumably not occur if there is only a single account's credentials saved. 

Reproducible: Always

Steps to Reproduce:
1.Create a profile with multiple saved credentials.
2.Create a master password.
3.Start Thunderbird with said profile.
Actual Results:  
The master password dialog comes up several times, each having to be individually dealt with. 

Expected Results:  
There should only be one master password dialog.
(In reply to comment #0)
> Previous to this version, this did not happen. Several nightly versions before
> this one, Thunderbird would not even execute the main window thread without
> having first dealt with the master password dialog, which would avoid this
> problem in the first place. In any case, this would be the preferred behavior,
> as with the new automatic IMAP local cache, emails can be easily accessed if
> the dialog was dismissed.

Note: The master password is NOT designed to protect your emails, only your passwords. There is nothing to stop very-slightly-knowledgeable users accessing your emails via your disk drive if you leave your computer unsecured.

This bug is in any case a duplicate of bug 437635.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 437635
Hmm, I see.
I don't care so much for my own emails, but that was what I assumed was done when it didn't show in previous versions.
In any case, it's odd that the original bug did not show when I did a search for "master password".
Yeah, I'd contend that this isn't a duplicate of the older bug. I suspect this is a regression caused by the fix for the older bug. It's just started happening for me, too.
Apologies, I misread. It's not technically a duplicate, but the recent regression was dealt with in that bug.
You need to log in before you can comment on or make changes to this bug.