If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

X Window error when trying to open GIF in FF3; tab with draw errors in FF3.1+

RESOLVED DUPLICATE of bug 424333

Status

()

Core
Graphics
--
critical
RESOLVED DUPLICATE of bug 424333
9 years ago
9 years ago

People

(Reporter: Claudio Fontana, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.4) Gecko/2008102920 Firefox/3.0.4

While browsing (using a single window/single tab), I got a crash trying to open 

http://www.elementk.com/s.asp?p=17999

Therefore, I disabled all add-ons and then tried to start firefox again.
I get asked if I want to go to the last page and I answer yes.
Crash again.

I tried to start a new session and only then go to the page, and it crashes again. This happens 100% of times, 16 attempts tried.

I tried running firefox in a gdb session by adding '-g -d gdb' to the run-mozilla.sh script.

Here I get something a little bit different. Instead of crashing, firefox just completely blocks while rendering the page (some output of the page is visible).



Reproducible: Always

Steps to Reproduce:
1.start firefox
2.enter http://www.elementk.com/s.asp?p=17999 in the main location bar
3.firefox should crash during page loading, after about 2 seconds.

Actual Results:  
firefox window disappeared.
firefox-bin disappeared from the process list.


Expected Results:  
I had expected a rendering of the page.

I am running Slackware 12.1, kernel 2.6.27.4, x86 architecture.
No special themes installed or anything. All add-ons disabled, with the exception of the default plugin.

NO DESKTOP ENVIRONMENT. Using plan XOrg + fluxbox.
For everything else, the browser works very well (I use the browser heavily).
Only that particular web page causes the trouble.

Comment 1

9 years ago
It's an X Window error, not a crash. Terminal output:
The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 51196 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

Easily reproducible with Firefox 3.0.5 on Kubuntu 8.04.1.

However, I also tested with 3.1b3pre and 3.2a1pre and got different results. These newer builds don't get this error, but instead get a broken tab. Firefox itself works seemingly fine but when the tab is selected whatever is onscreen stays drawn there. (previous tab, other windows, tooltips, etc.) There is no terminal output and no errors in the error console.

I'll confirm this for now based on the second part, but it may be an Xorg issue.
Severity: normal → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: firefox crashes while trying to open URL. → X Window error when trying to open URL in FF3; tab with draw errors in FF3.1+

Comment 2

9 years ago
It's caused by their background image. Just go here reproduce:
http://www.elementk.com/gfx/bg2.gif
Summary: X Window error when trying to open URL in FF3; tab with draw errors in FF3.1+ → X Window error when trying to open GIF in FF3; tab with draw errors in FF3.1+

Comment 3

9 years ago
For what it's worth, I get no problems testing in Windows XP.

KDE tells me this thing is an 8x64000 pixel GIF version 89a.

This looks like a dupe of bug 424333, however the sample GIF attached over there doesn't cause the draw problems in FF3.1 that the one here does, so they may not be exactly the same.

Updated

9 years ago
Component: General → GFX
Product: Firefox → Core
QA Contact: general → general
(Reporter)

Comment 4

9 years ago
http://www.elementk.com/gfx/bg2.gif(In reply to comment #2)
> It's caused by their background image. Just go here reproduce:
> http://www.elementk.com/gfx/bg2.gif

This might be the fastest reply to any bug report I submitted ever.

I tried to open http://www.elementk.com/gfx/bg2.gif in a new tab, but I do not
get any error there.

The title of the window is 
"bg2.gif (GIF Image, 8x64000 pixels) - Scaled (1%) - Mozilla Firefox"
and nothing more is shown (just empty white space).
Firefox does not die though.

Instead, if I browse the main URL above, firefox is killed, or if I understand
it correctly, forcefully disconnected from the X server.

Comment 5

9 years ago
(In reply to comment #4)
> I tried to open http://www.elementk.com/gfx/bg2.gif in a new tab, but I do not
> get any error there.

Odd, I do. What's your X version? (command: X -version)
It says I'm using: X.Org X Server 1.4.0.90
(Reporter)

Comment 6

9 years ago
(In reply to comment #5)
> (In reply to comment #4)
> > I tried to open http://www.elementk.com/gfx/bg2.gif in a new tab, but I do not
> > get any error there.
> 
> Odd, I do. What's your X version? (command: X -version)
> It says I'm using: X.Org X Server 1.4.0.90

Same here. I got what triggers the problem on my side.

I confirm it is the GIF that triggers it, exactly like the .asp page.
The reason I got a different behaviour the second time around, when I opened the GIF in a new tab, was that the conditions were a little different.

Here's the scoop: when I start firefox under a controlling xterm
(open an xterm. Run firefox script) the problem does not present itself.

When I start firefox directly from fluxbox, the problem presents itself, and I can admire the X BadAlloc error on my tty1.
(Reporter)

Comment 7

9 years ago
> Here's the scoop: when I start firefox under a controlling xterm
> (open an xterm. Run firefox script) the problem does not present itself.
> 
> When I start firefox directly from fluxbox, the problem presents itself, and I
> can admire the X BadAlloc error on my tty1.

NB! I just noticed that when I start firefox from the terminal I actually get the slackware version (2.0.0.14) in /usr/bin aka /usr/lib/firefox which does not have the problem.

When I start firefox from fluxbox I get the 3.0.4 version I got from mozilla.org, in /opt/firefox, which _does_ show the issue.

I tried starting /opt/firefox/firefox from an xterm, and the problem _does_ present itself.

Sorry for the confusion.

Here is again the error as I get it:

The program 'firefox-bin' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 140384 error_code 11 request_code 53 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)
/opt/firefox/run-mozilla.sh: line 131:  3594 Segmentation fault      "$prog" ${1+"$@"}
(Assignee)

Updated

9 years ago
Product: Core → Core Graveyard

Updated

9 years ago
Component: GFX → GFX: Thebes
Product: Core Graveyard → Core
QA Contact: general → thebes
Whiteboard: dupeme?

Comment 8

9 years ago
Based on bug 476768 comment 2 I was right up in comment 3 here and this is a dupe of bug 424333. Marking as such.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Whiteboard: dupeme?
Duplicate of bug: 424333
You need to log in before you can comment on or make changes to this bug.