DOM Inspector does not work. Could not convert JavaScript argument (NS_ERROR_XPC_BAD_CONVERT_JS)

RESOLVED FIXED

Status

()

Core
XPConnect
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: Atsushi Sakai, Unassigned)

Tracking

({regression})

Trunk
regression
Points:
---
Bug Flags:
blocking1.9.2 +

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

(Reporter)

Description

9 years ago
DOM Viewer of DOM Inspector does not work correctly on trunk Firefox.

uncaught exception: [Exception... "Could not convert JavaScript argument"  nsresult: "0x80570009 (NS_ERROR_XPC_BAD_CONVERT_JS)"  location: "JS frame :: chrome://inspector/content/viewers/dom/dom.js :: anonymous :: line 169"  data: no]
occurs at
      selectedNode = new XPCNativeWrapper(viewer.selectedNode, "nodeType",
                                          "parentNode", "childNodes");

2009010603 works fine.
2009010703 fails.

Is this dupe of Bug 472674?
Flags: blocking1.9.2?
Yes, it'll be fixed tomorrow.
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Yes, it'll be fixed tomorrow.

Thanks.
-> FIXED
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED

Updated

9 years ago
Flags: blocking1.9.2? → blocking1.9.2+
Mass change: adding fixed1.9.2 keyword

(This bug was identified as a mozilla1.9.2 blocker which was fixed before the mozilla-1.9.2 repository was branched (August 13th, 2009) as per this query: http://is.gd/2ydcb - if this bug is not actually fixed on mozilla1.9.2, please remove the keyword. Apologies for the bugspam)
Keywords: fixed1.9.2
status1.9.2: --- → beta1-fixed
Keywords: fixed1.9.2
You need to log in before you can comment on or make changes to this bug.