Can't drag content into textboxes

VERIFIED FIXED in M18

Status

()

P4
normal
VERIFIED FIXED
19 years ago
18 years ago

People

(Reporter: bugzilla, Assigned: mikepinkerton)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3+][minus])

(Reporter)

Description

19 years ago
Build ID: 2000080208 M18 Win98

You can no longer drag links/plain text from one page into HTML textboxes that 
are in the same page.  This is due to pink's d&d changes...

Comment 1

19 years ago
this sounds a *lot* like #44310
here's the problem as i see it:

editor may very well set the dragSession.canDrop flag to true but the event is 
bubbling up to the content area which then sets the flag to false. 

when realizing a drag event can be handled, ender needs to call PreventBubble() 
on the dom event to stop anyone else from seeing it.
Assignee: pinkerton → kin

Comment 3

19 years ago
setting to nsbeta3+
Keywords: correctness, nsbeta3
Priority: P3 → P4
Whiteboard: [nsbeta3+]
Target Milestone: --- → M18
(Reporter)

Comment 4

19 years ago
This isn't 44310; This just broke with pink's changes.  44310 is textbox to 
textbox, this is anything to textbox.
(Reporter)

Updated

19 years ago
Blocks: 48525
(Reporter)

Updated

19 years ago
No longer blocks: 48525

Comment 5

19 years ago
adding pink to cc list -- pink, any idea as to what changes you made to make 
this happen?
yeah, i changed things in navigator's d&d. the problem is that this is bubbling 
up to navigator and it's being rejected there after being approved by editor. 
just don't bubble.

Comment 7

19 years ago
Passing to anthonyd ... the new editor D&D master. ;-)
Assignee: kin → anthonyd

Comment 8

19 years ago
oh man.  pink can I meet with you to go over this?
Status: NEW → ASSIGNED
sure tony, come over when you want to chat.

Comment 10

19 years ago
PDT is downgrading to [nsbeta3-], this is not critical to PR3 and RTM.  User can 
cut and paste content.
Whiteboard: [nsbeta3+] → [nsbeta3-][minus]

Comment 11

19 years ago
no, putting back on radar
Whiteboard: [nsbeta3-][minus] → [nsbeta3+][minus]

Comment 12

19 years ago
reassiging but to pinkerton for him to close.  i sat with him and saw his fix, 
all is good.  he will check it in when the tree opens.

anthonyd
Assignee: anthonyd → pinkerton
Status: ASSIGNED → NEW
shaZAAAM!
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

19 years ago
vrfy fixed in a build just pulled on win98. nice job. now if only 44310 were 
fixed...
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.