impossible to set Thunderbird colors, pick up theme from GTK's settings

RESOLVED DUPLICATE of bug 456829

Status

RESOLVED DUPLICATE of bug 456829
10 years ago
10 years ago

People

(Reporter: hramrach, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: version 2.0.0.19 (20081209)



Reproducible: Always

Steps to Reproduce:
1. Install thunderbird
2. change your GTK color theme
Actual Results:  
- messages are not displayed in the theme colors
- after setting message colors and quote color quotes in reply are still displayed blue while composing a message, and so are the quotation marks
- links are blue

The result is that usability of Thunderbird suffers.

It cannot pick up theme colors that are easy to read automatically, they have to be set separately, and there are some colors that cannot be changed which can result in unreadable or completely invisible text.

Expected Results:  
It is possible to set any color displayed

colors are picked from the system theme
(Reporter)

Comment 1

10 years ago
In TB3b1 all the problems remain.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20081204 Thunderbird/3.0b1

In addition the message header area does not pick system colors, it has hardcoded colors.
Flags: wanted-thunderbird3?
Summary: impossible to set Thunderbird colors → impossible to set Thunderbird colors, pick up theme from GTK's settings
I believe we fixed this for TB3b2. bug 461098 landed the changes you want.  This might want to be duped against bug 456829 though.
Michale can you test with tb3.0b2 ? reopen if you still have issue with it or nightlies.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 456829
Flags: wanted-thunderbird3?
You need to log in before you can comment on or make changes to this bug.