If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Drag 'n drop emails on sub folders not possible

RESOLVED WORKSFORME

Status

Thunderbird
Mail Window Front End
RESOLVED WORKSFORME
9 years ago
7 years ago

People

(Reporter: OffHand, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [has protocol logs])

Attachments

(3 attachments)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090120 Shiretoko/3.1b3pre Ubiquity/0.1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090120 Shredder/3.0b2pre

For instance: I am not able to drag n drop an email to Archive/foldername. With my Gmail account I am able drag n drop an email on a sub folder of Inbox, Inbox/foldername. It does work with the Win32 build. Seems like a GTK error.

More info will be provided if requested.

Reproducible: Always

Steps to Reproduce:
1.See details. That explains it all.
2.
3.
Actual Results:  
See details.

Expected Results:  
Allow me to drag n drop the email on Archive/foldername.
(In reply to comment #0)
> For instance: I am not able to drag n drop an email to Archive/foldername. With
> my Gmail account I am able drag n drop an email on a sub folder of Inbox,
> Inbox/foldername. It does work with the Win32 build. Seems like a GTK error.

Are there any errors in the Error Console?

CC'ing Magnus who uses Linux and bienvenu who has been working away on Archive.

-> Mail Window Front End.
Component: General → Mail Window Front End
QA Contact: general → front-end
Version: unspecified → Trunk
(Reporter)

Comment 2

9 years ago
For the record... Archive is just a folder I manually created.
(Reporter)

Comment 3

9 years ago
Warning: Timed textboxes are deprecated. Consider using type="search" instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

I also started it from the command line but no trace back there either.
(Reporter)

Comment 4

9 years ago
If you need an email account on my server to test it with, feel free to send me an email and I'll make a test account. Although I think it isn't server related because it works with the Win32 build.

Comment 5

9 years ago
Created a folder Archive and a subfolder test. Dropping a mail on it is WFM for me, on linux.
(Reporter)

Comment 6

9 years ago
I am running Cyrus v2.3.8-OS X Server 10.5

It also works for me with Gmail (which uses subfolders of Inbox) and I am able to drag n drop on the Archive folder itself, just not on the subfolders.

With the Win32 build I have no issues. I remember that at one point this was also an issue on TB 2.
(Reporter)

Comment 7

9 years ago
It seems like I can drag n drop on the subfolders of Archive but not the last few because they are too low on the screen. The problem is that even though I have closed as much as possible in the account bar my screen is just too small to  scroll the last few folders enough up to be in the drag-able area.
Offhand, do you see this with 3.0b3pre?
(Reporter)

Comment 9

9 years ago
Unfortunately yes.
Hm, works for me running Fedora nightlies https://wiki.mozilla.org/Thunderbird:QA_TestDay:2009-05-14
(Reporter)

Comment 11

9 years ago
Also if you have a lot of subfolders? The original bug has been narrowed down. 

"It seems like I can drag n drop on the subfolders of Archive but not the last
few because they are too low on the screen. The problem is that even though I
have closed as much as possible in the account panel my screen is just too small
to  scroll the last few folders enough up to be in the drag-able area."

Comment 12

8 years ago
Confirmed here, running latest nightly on Ubuntu 9.10 alpha4

I have 8 sub-folders below the Inbox of my Gmail account. I can drag-and-drop messages to the top 3 folders but not the lower 5

(for now I am working around this using the quickfile addon)
Ok, can we get Imap logs when the issue is happening ? (https://wiki.mozilla.org/MailNews:Logging for instructions on capturing logs)

Comment 14

8 years ago
Sorry Ludovic, following those instructions I'm told the setenv package is not available - perhaps it's outdated or just not in Karmic yet. Hope someone more able can help with a log...

Interestingly, I remember NOT having this problem with beta3, but others above were posting on earlier versions...

Have also just remembered to start a new profile. Same result - first 3 sub-folders can have messages dragged, 4th cannot. Good luck!
Setenv is to be executed when you are running csh/tsch, you just need to do the two lineas above with the export - that will create the logs (as I assume you are running bash as you default terminal)

Comment 16

8 years ago
Created attachment 396190 [details]
POP3 log from rogerdean's gmail

Got it, thanks. Imap log was blank - I assume you need the pop3 log
(In reply to comment #16)
> Created an attachment (id=396190) [details]
> POP3 log from rogerdean's gmail
> 
> Got it, thanks. Imap log was blank - I assume you need the pop3 log

Well so your issue is on local folders or also on folders that are hosted on Gmail ?
Attachment #396190 - Attachment mime type: application/octet-stream → text/plain

Comment 18

8 years ago
Created attachment 396404 [details]
IMAP log of rogerdean's Gmail

Both I think. I have tried new profiles using my Gmail account. First, when I set it up as POP3 and manually created my sub-folders (as above), I could drag-and-drop to only the first 3 sub-folders

Then I set it up again using Gmail IMAP, and could drag-and-drop only to the first 2 Google sub-folders (drafts and sent) but not to others (all-mail, spam, bin or starred) nor to outbox or trash under local folders.

The IMAP log is attached from the second experiment. Hope this helps

Cheers
Roger
(Reporter)

Comment 19

8 years ago
Created attachment 396524 [details]
imap log offhand

imap log as requested. hope it helps.
Attachment #396524 - Attachment mime type: text/x-log → text/plain
(In reply to comment #19)
> Created an attachment (id=396524) [details]
> imap log offhand
> 
> imap log as requested. hope it helps.

Where where you trying to copy the message from and where were you trying to copy it to (which folders) ?
(Reporter)

Comment 21

8 years ago
From Inbox to Shannon which is a subfolder of Inbox. The account is a Gmail IMAP account.
Don't see the move/copy happening in the log. Issue might be "UI" - only.
Whiteboard: [has protocol logs]

Comment 23

8 years ago
I would suspect so, yes
(Reporter)

Comment 24

8 years ago
Do you run Compiz Roger?

Comment 25

8 years ago
No I don't - my Intel chipset can't do it very comfortably...

Comment 26

8 years ago
Seems to be fixed as of latest nightly build. Many thanks to all!
(Reporter)

Comment 27

8 years ago
I'll test it on my machine tonight and report back...
(Reporter)

Comment 28

8 years ago
It is still not working for me...

Comment 29

8 years ago
(In reply to comment #28)
> It is still not working for me...

I am on Fedora 8 and I installed the nightly, Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9.1.5pre) Gecko/20091015 Shredder/3.0pre.
I created a new profile, added folders below inbox and also in local folders. I created 2 new local folders and 2 sub folders of 1 local folder. Move msg to folder works. Edit/undo move works as well.
I created nested folders, 4 levels below the top - does that make 5 levels - and move msg worked for nested folders too. WFM Lenny
(Reporter)

Comment 30

8 years ago
5 subfolders wfm too. Try 15 or 20.
(In reply to comment #12)
> I have 8 sub-folders below the Inbox of my Gmail account.
> I can drag-and-drop messages to the top 3 folders but not the lower 5

It sounds same as Bug 507553 due to Gmail's restriction?
(In reply to comment #31)
> (In reply to comment #12)
> > I have 8 sub-folders below the Inbox of my Gmail account.
> > I can drag-and-drop messages to the top 3 folders but not the lower 5
> 
> It sounds same as Bug 507553 due to Gmail's restriction?

Offhand do you agree ?
(Reporter)

Comment 33

8 years ago
I don't think it's only gmail. IIRC it also happened on my own OS X (mail) server. Will test and report back tonight.
(Reporter)

Comment 34

8 years ago
Like a week ago I replaced my 32bit system with a 64bit system and currently I do not experience this bug anymore. Thunderbird is still a 32bit app though.
WFM per reporter


(In reply to comment #31)
> (In reply to comment #12)
> > I have 8 sub-folders below the Inbox of my Gmail account.
> > I can drag-and-drop messages to the top 3 folders but not the lower 5
> 
> It sounds same as Bug 507553 due to Gmail's restriction?

why is bug 507553 still unconfirmed?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.