Closed Bug 474556 Opened 14 years ago Closed 13 years ago

Copy & paste of events does not correctly update alarms in all cases

Categories

(Calendar :: Alarms, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 360916

People

(Reporter: en, Unassigned)

Details

User-Agent:       Opera/9.63 (Windows NT 5.1; U; en) Presto/2.1.1
Build Identifier: Lighting 0.9

The alarms of events generated with copy & paste do get updated correctly in all cases.
One way to reproduce this is detailed below.

Although I could not reproduce this forcefully, I also have other problems with the alarms of events (i believe) created with copy & paste. Today, an alarm for an event exactly in one month popped up, even though it's alarm time is set to Custom (3 hours before). I'm not 100% sure that it was created by copy/paste, but I think so. As it is not the same symptom described above (were both alarms fire at the same time), I think it is another problem.
Maybe the whole copy/paste mechanism should be inspected thoroughly.

Maybe this should be classified as a major bug, as alarms are a key feature of the calender and don't work as expected. On the other hand, at least (with this special bug), the alarms don't show up after the event, so you can (as a workaroung) dismiss them until they should really fire manually.

Reproducible: Always

Steps to Reproduce:
1. Create a new event on current day half an hour from now, with an alarm of 1 hour before.
2. On saving, the alarm pops up. Dismiss the alarm for 1 minute.
3. Copy and paste the event to the current day.
4. Edit one instance of the event to start on some future day.
5. Wait for the alarm to pop up.
Actual Results:  
The alarm popup will show reminders for both events, although the future event still shows its alarm beeing '1 hour before'

Expected Results:  
Only one alarm should display, the other one when it is intented to.

Windows XP SP3, Mozilla Thunderbird 2.0.0.19 (20081209)
You mentioned two issues in this report:

1. After snoozing the alarm it will be displayed after the snooze time although the event time has been changed in between. See Bug 360916 for this issue.

2. Copying an event copies its alarm including snooze and dismiss status too. It should be checked if this behavior works as specified. After all your are creating a copy. In that case this issue is invalid and this is just a duplicate of Bug 360916.
You are right, the issue illustrated with my step-by-step instructions is a duplicate of #360916.
The second issue mentioned (the alarm that fired although the event beeing 1 month in the future and the reminder configured to 3 hours before) seems to be an other one. Unfortunately, I can't reproduce it.
Resolving this bug as duplicate (confirmed by reporter in comment#2).

Nicolai, if you can reproduce the second issue (reminder shows up early) again, feel free to file a new bug report with the details.
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 360916
You need to log in before you can comment on or make changes to this bug.