The form on the above page isn't displayed correctly.

VERIFIED WONTFIX

Status

()

Core
Layout: Form Controls
P3
normal
VERIFIED WONTFIX
18 years ago
17 years ago

People

(Reporter: Tomer Brisker, Assigned: buster)

Tracking

({top100})

Trunk
x86
Linux
top100
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.16 i686; en-US; m18) Gecko/20000801
BuildID:    2000080108

The form on the URL is not displayed correctly. This might also be related to
tables and/or layout.

Reproducible: Always
Steps to Reproduce:
1. Go to http://promotions.yahoo.com/promotions/netiquette/

Actual Results:  The form is not displayed properly- the radio buttons are
missing, and so is the "true" word before every false. Also, the word "false" is
displayed sometimes over other text.

Expected Results:  True/False radio buttons appear to the right of each question.

Comment 1

18 years ago
The code on this page barely qualifies as HTML.  CDATA attribute values are
unquoted.  The tables are specified in absolute pixel sizes.  No DOCTYPE.  Etc,
etc.  Not confirming because of the bad code issues, but adding top100 keyword
and moving to layout.
Assignee: rods → clayton
Component: HTML Form Controls → Layout
Keywords: top100
QA Contact: ckritzer → petersen
(Reporter)

Comment 2

18 years ago
I agree that the code is bad, but it still displays correctly on both netscape 4
and IE 5. Adding 4xp keyword.
Keywords: 4xp

Comment 3

18 years ago
setting bug status to New.  Confirmed with 082408 mozilla win32 build on NT.
Over to form controls.
Assignee: clayton → rods
Status: UNCONFIRMED → NEW
Component: Layout → HTML Form Controls
Ever confirmed: true
QA Contact: petersen → ckritzer

Comment 4

18 years ago
Created attachment 13613 [details]
reduced testcase

Comment 5

18 years ago
Looks like another align-right (floater) bug. If I remove the align=right from 
the inner table it tart looking better.
Assignee: rods → attinasi

Comment 6

18 years ago
Chris, this is probably a dup of another bug but I couldn't find it... Yet 
Another Floater Problem.
Assignee: attinasi → karnaze

Comment 7

18 years ago
PDT: Nominating for nsbeta3+
Reason: Forms, top100 site, high visibility;

Additional info:  seems to be related to dispersing form controls in a table.
Keywords: nsbeta3

Comment 8

18 years ago
Buster, this looks like a floater problem (I don't have your recent fixes). When 
the align=right is removed from the nested table in the attachment, the "true" 
radio shows up.
Assignee: karnaze → buster
(Assignee)

Comment 9

18 years ago
this is another instance of a page that relies on quirky behavior of inline 
elements in an overconstrained situation.  marking WontFix, adding evangwanted.  
Will attach a reduced test case.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Keywords: evangwanted
Resolution: --- → WONTFIX
(Assignee)

Comment 10

18 years ago
Created attachment 14649 [details]
more detailed test case, showing the error in the source and how it can be fixed using either NOBR, or explicit widths (not as effective, depends on user's fonts)
(Assignee)

Comment 11

18 years ago
as noted in other bugs of this sort, NOBR is non-standard.  Better solutions 
include using the NOWRAP attribute on the TD, or better yet the CSS property 
"white-space: nowrap"

Comment 12

18 years ago
Updating QA contact.
QA Contact: ckritzer → bsharma

Updated

18 years ago
Keywords: evangwanted

Comment 13

17 years ago
verified
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.