Subscribe dialog unusably slow.

VERIFIED DUPLICATE of bug 54491

Status

P3
critical
VERIFIED DUPLICATE of bug 54491
19 years ago
11 years ago

People

(Reporter: jg, Assigned: sspitzer)

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.73 [en] (X11; I; Linux 2.2.16 i586)
BuildID:    2000073104

If you create a new newsgroup acccount, and go into the subscription dialog,
mozilla starts downloading a list of available groups. However after over 15
minutes downloading and after the modem had stopped for some time, the dialog
hadn't displayed any groups.

Reproducible: Always
Steps to Reproduce:
1. Open new newsgroup account
2. Open subscription dialog
3. Wait forever for new groups to arrive

Actual Results:  Nothing. Mozilla became very slow to respond, taking several
seconds to close the subscribe dialog after I hit cancel. This prevents any
subscriptions to newsgroups and thus furter testing from taking place.

Expected Results:  Dialog should have displayed a list of available groups.

This was using the latest M17 build, Aug 02 2000. It has happened several times
before. It should be noted that the problem occurs on several news servers/isps
and that non of them require authentication nor have they authentication
required selected.

Also, if you cancel this dialog then close mail/news window, then take the
browser to the advanced bug reporting page, you'll notice that typing text is
very slow indeed. Close Mozilla entirely and it will never die, 'top' shows
mozilla's RSS memory steadily going up from around 28MB to over 36MB; you must
ctrl-c the application before you run out of memory!
(Reporter)

Comment 1

19 years ago
OK an update to this. Downloaded M18 latest and tried again at Blizzard's
request. Did rm -rf ~/.mozilla before I ran it, and create a new profile, hit
'Subscribe...' and waited. It downloaded the newsgroups as before, then
everything stopped. I want away, read the paper, cup of coffee, etc., came back
and still nothing worked. 'top' showed mozilla using a whole lot of memory
(around 36MB) and using a lot of cpu (over 50% IIRC). A few minutes more and a
list of top-level groups appeared! Scolling down them took an age but they were
there!

I subscribed to one of them, a fairly low-traffic group, and once again there
was a delay of a few minutes complete with my disks thrashing with memory usage.

Managed to download headers and read a few messages, then clicked 'Subscribe...'
again and saw over the course of the next five minutes mozilla go from 38MB RSS
to 42MB RSS and going up. Nothing I could do but ctrl-c the app since nothing
was responding.

I'd say there are very serious mem leaks in that area and it's unusably slow.
Spending ten minutes to view a list of top-level groups is totally unacceptable
and will be seen as a crasher bug by users.

My machine: K6-2 300Mhz, 64MB RAM plus 128MB Swap running Debian Woody with XF86
3.3. Communicator 4.7 on this is orders of magnitude faster in newsgroups.

I suggest leaving as a blocker since it renders newsgroups unsubscribable to me,
I'm not spending ten minutes or more waiting for a list to be displayed.

I'm guessing that the same things are happening in M17.

Changing Summary to a more appropriate text.
Summary: Subscribe dialog never finishes downloading list of groups → Subscribe dialog unusably slow.
(Reporter)

Comment 2

19 years ago
Amplification on last comment: I was using a build from latest/. Could be M17 or
M18. Why aren't these marked! :(
(Reporter)

Comment 3

19 years ago
OK according to Help->About it was an M17 build I was using 2nd time around. So
no M18 builds tested.
Confirming, as this has been seen on several builds. Downgrading to critical 
(does not block development.)

Gerv
Severity: blocker → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 5

19 years ago
moving to future milestone. We've chosen not to focus on the subscribe dialog 
performance issues. There's also another bug to implement stop in this dialog.
Target Milestone: --- → Future
accepting all "future" bugs to get them off my "new" bug radar.
Status: NEW → ASSIGNED
Looks like a dup of bug 39760.

*** This bug has been marked as a duplicate of 54491 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 9

18 years ago
marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey

Updated

11 years ago
Component: MailNews: Subscribe → MailNews: Message Display
QA Contact: lchiang → search
You need to log in before you can comment on or make changes to this bug.