Closed Bug 474602 Opened 11 years ago Closed 11 years ago

@mozilla.org/oji/jvm-mgr;1 stopped working in Firefox 3.1 beta 2

Categories

(Firefox Build System :: General, defect, P1)

x86
All
defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla3.1b3

People

(Reporter: ignisvulpis, Assigned: philor)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b2) Gecko/20081201 Firefox/3.1b2

if you enter
"Components.classes["@mozilla.org/oji/jvm-mgr;1"].getService(Components.interfaces.nsIJVMManager)"
into the command line of the Firefox console then Firefox 3.0.5 returns
"[xpconnect wrapped nsIJVMManager]" 
while Firefox 3.1 beta 2 returns 
"Fehler: Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]
Quelldatei: javascript:%20Components.classes["@mozilla.org/oji/jvm-mgr;1"].getService(Components.interfaces.nsIJVMManager)
Zeile: 1".

Reproducible: Always

Steps to Reproduce:
if you enter
"Components.classes["@mozilla.org/oji/jvm-mgr;1"].getService(Components.interfaces.nsIJVMManager)"
into the command line of the Firefox console then Firefox 3.0.5 returns
"[xpconnect wrapped nsIJVMManager]" 
while Firefox 3.1 beta 2 returns 
"Fehler: Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID) [nsIJSCID.getService]
Quelldatei: javascript:%20Components.classes["@mozilla.org/oji/jvm-mgr;1"].getService(Components.interfaces.nsIJVMManager)
Zeile: 1".
Version: unspecified → 3.1 Branch
FYI: The old Oji Java interface is removed with FF3.1 and the Java plugin is using the normal NPAPI.
Well, yes. This is what 
https://bugzilla.mozilla.org/show_bug.cgi?id=442399
announces. But how do I open the jvm console from an extension then?
(In reply to comment #1)
> FYI: The old Oji Java interface is removed with FF3.1 and the Java plugin is
> using the normal NPAPI.

Not true, we still ship with OJI enabled as the new Java plugin is not yet available on enough platforms (i.e. doesn't work on the Mac yet).

This looks to be a build config issue, as this works in builds that I spin myself (at least w/o libxul enabled), but not in our nightlies or releases. Confirming, and over to build config. I'd mark this a blocker, but I don't know who to give it to... But it is a P1 blocker, really.
Status: UNCONFIRMED → NEW
Component: Extension Compatibility → Build Config
Ever confirmed: true
Flags: blocking-firefox3.1?
Priority: -- → P1
QA Contact: extension.compatibility → build.config
"@mozilla.org/oji/jvm-mgr;1" in Components.classes
true
"nsIJVMManager" in Components.interfaces
false

I'd say with about 99% certainty that this is a packaging issue. Is your xpt file listed in packages-static? (both the windows and unix variants) If not, it won't get shipped with the build.
It is (well, assuming that MODULE = oji is putting it into oji.xpt), inside the #ifdef MOZ_OJI I added when I got tired of seeing the "possible missing or unnecessary" in the tinderbox logs while OJI was disabled.

And now, if you look down at the end of the logs where the packaging spew is, you see no mention of oji.xpt, and if you look up at the top where there's all the #define MOZ_FOO, #define MOZ_BAR, there's a #define OJI 1 instead of a MOZ_OJI, and I'm not at all sure where that's coming from.
Oh, I see, there's both #ifdef OJI and #ifdef MOZ_OJI, because I'm not confused enough on my own.
Attached patch FixSplinter Review
So lovely. At least this time I tested that it works enabled, and not just disabled like I apparently did before.
Assignee: nobody → philringnalda
Status: NEW → ASSIGNED
Attachment #358668 - Flags: review?(gavin.sharp)
Attachment #358668 - Flags: review?(gavin.sharp) → review+
Target Milestone: --- → Firefox 3.1b3
http://hg.mozilla.org/mozilla-central/rev/efb64de1df3a
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
OS: Windows XP → All
Resolution: --- → FIXED
Version: 3.1 Branch → Trunk
Flags: blocking-firefox3.1? → blocking-firefox3.1+
Flags: in-testsuite-
(In reply to Axel Nennker from comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b2)
> Gecko/20081201 Firefox/3.1b2
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1b2)
> Gecko/20081201 Firefox/3.1b2
> 
> if you enter
> "Components.classes["@mozilla.org/oji/jvm-mgr;1"].getService(Components.
> interfaces.nsIJVMManager)"
> into the command line of the Firefox console then Firefox 3.0.5 returns
> "[xpconnect wrapped nsIJVMManager]" 
> while Firefox 3.1 beta 2 returns 
> "Fehler: Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID)
> [nsIJSCID.getService]
> Quelldatei:
> javascript:%20Components.classes["@mozilla.org/oji/jvm-mgr;1"].
> getService(Components.interfaces.nsIJVMManager)
> Zeile: 1".
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> if you enter
> "Components.classes["@mozilla.org/oji/jvm-mgr;1"].getService(Components.
> interfaces.nsIJVMManager)"
> into the command line of the Firefox console then Firefox 3.0.5 returns
> "[xpconnect wrapped nsIJVMManager]" 
> while Firefox 3.1 beta 2 returns 
> "Fehler: Component returned failure code: 0x80570018 (NS_ERROR_XPC_BAD_IID)
> [nsIJSCID.getService]
> Quelldatei:
> javascript:%20Components.classes["@mozilla.org/oji/jvm-mgr;1"].
> getService(Components.interfaces.nsIJVMManager)
> Zeile: 1".
Component: Build Config → General
Product: Firefox → Firefox Build System
Keywords: fixed1.9.1
Target Milestone: Firefox 3.1b3 → mozilla3.1b3
You need to log in before you can comment on or make changes to this bug.