If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Waiting if Page Redirects Before Showing ssl_error_bad_cert_domain Error

RESOLVED DUPLICATE of bug 437978

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 437978
9 years ago
9 years ago

People

(Reporter: e.eydt, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

When you type in a url with https:// that has a bad Cert Domain the Browser shows an Error Message and Stops wich is a correct behavior. Now if the page that should be shown has a redirect to redirect you to a domain that has a correct Cert Domain the new Redirectet Page should be shown. But Firefox does not redirect and stays on the page with the SSL-Cert Domain Error Warning instead of waiting if this page maybe redirects to a valid ssl domain.

Example: 
https://www.domain.com has a valid SSL-Cert Domain.
https://www.domain.net has not a valid SSL-Cert Domain.
Typing https://www.domain.net gives out a ssl_error_bad_cert_domain
https://www.domain.net now redirects automatically to https://www.domain.com
Which would be valid, but firefox stays on the ssl_error_bad_cert_domain page and goes not directly to https://www.domain.com


Reproducible: Always

Steps to Reproduce:
1. You Need a domain with valid ssl
2. You Need a domain with invalid ssl, Error: Bad Cert Cert Domain
3. Setup a Redirect with .htaccess on the Domain with invalid SSL that redirects to the domain with valid SSL.
4. Type in the url with invalid ssl.
Actual Results:  
After Typing the URL with invalid ssl, firefox shows the ssl_error_bad_cert_domain Error asking you to add an exepction.

Expected Results:  
After Typing the URL with invalid ssl, firefox should show the URL with the Redirect, in this Case the url with valid ssl.
Component: General → Security
OS: Windows XP → All
QA Contact: general → firefox
Hardware: x86 → All
Version: unspecified → 3.0 Branch

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Component: Security → General
OS: All → Windows XP
QA Contact: firefox → general
Hardware: All → x86
Resolution: --- → DUPLICATE
Version: 3.0 Branch → unspecified
Duplicate of bug: 437978
You need to log in before you can comment on or make changes to this bug.