Snooze or dismiss of alarms doesn't work

RESOLVED FIXED in 1.0b1

Status

RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: ssitter, Assigned: ssitter)

Tracking

({regression})

Trunk
1.0b1
regression
Dependency tree / graph

Details

Attachments

(1 attachment)

(Assignee)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090121 Calendar/1.0pre (BuildID: 20090121080753)

Steps to Reproduce:
1. Create a non-repeating event (due to Bug 474630) with alarm
2. Wait until the alarm fires and snooze or dismiss the alarm

Actual Results:
Pressing snooze or dismiss does nothing, the alarm dialog is still displayed. Pressing again trows a MODIFICATION_FAILED error.

Expected Results:
Alarm can be snoozed or dismissed.

Additional Information:
Tested with both storage and ics provider.
(Assignee)

Comment 1

10 years ago
Regression range: Works in Sunbird 1.0pre (2009-01-19-02-40-56)
                  Fails in Sunbird 1.0pre (2009-01-19-03-24-18)

Checkins: https://hg.mozilla.org/comm-central/pushloghtml?startdate=2009-01-19+02:00&enddate=2009-01-19+04:00
(Assignee)

Updated

10 years ago
Blocks: 474276
(Assignee)

Comment 2

10 years ago
We need to update http://mxr.mozilla.org/comm-central/source/calendar/base/src/calAlarmMonitor.js#41 because Bug 474276 changed the windows type.
(Assignee)

Comment 3

10 years ago
Created attachment 357993 [details] [diff] [review]
use correct windowtype
Assignee: nobody → ssitter
Attachment #357993 - Flags: review?(philipp)
Attachment #357993 - Flags: review?(philipp) → review+
Comment on attachment 357993 [details] [diff] [review]
use correct windowtype

Good catch, thanks for the patch!
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/7fdf4014635a>

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Windows XP → All
Hardware: x86 → All
Resolution: --- → FIXED
Target Milestone: --- → 1.0
(Assignee)

Updated

10 years ago
Blocks: 474646
Target Milestone: 1.0 → 1.0b1
You need to log in before you can comment on or make changes to this bug.