Last Comment Bug 47464 - getURLForIndex method in History interface do not work
: getURLForIndex method in History interface do not work
Status: VERIFIED FIXED
:
Product: Core Graveyard
Classification: Graveyard
Component: Java APIs to WebShell (show other bugs)
: Trunk
: All All
: P3 normal (vote)
: ---
Assigned To: edburns
: geetha.vaidyanaathan
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2000-08-03 09:00 PDT by Vladimir Strigun
Modified: 2012-04-09 22:27 PDT (History)
2 users (show)
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
cvs diff -u of fix for this bug, first iteration. (5.54 KB, patch)
2000-11-08 17:10 PST, edburns
no flags Details | Diff | Splinter Review

Description Vladimir Strigun 2000-08-03 09:00:23 PDT
getURLForIndex with correct parameter thrown a raptorWebShellGetURL exception 
and do nothing.
How to reproduce:
Load 4 pages and try to call method getURLForIndex with correct index (0,1,2,3) 
and note that exception raptorWebShellGetURL thrown.
Suggested reason:
Typematch in file /mozilla/java/webclient/src_moz/HistoryImpl.cpp:305
      wsGetURLForIndexEvent * actionEvent = 
	new wsGetURLForIndexEvent(initContext->sHistory,
				  historyIndex);
If change initContext->sHistory to sHistory in this line, then it will works 
correctly.

Reproduced on Mozilla M16 and Webclient sources from 07.31.2000
Comment 1 Gervase Markham [:gerv] 2000-08-20 06:55:01 PDT
Confirming due to high quality. edburns@acm.org is the man for this file.

Gerv
Comment 2 edburns 2000-08-21 17:17:49 PDT
I accept
Comment 3 edburns 2000-11-08 17:01:46 PST
Vladimir's fix does work.  I'll attach a patch for review.

Ed
Comment 4 edburns 2000-11-08 17:10:33 PST
Created attachment 18972 [details] [diff] [review]
cvs diff -u of fix for this bug, first iteration.
Comment 5 edburns 2000-11-08 17:11:23 PST
This fix removes gHistory, and makes it so History.getURLForIndex()
works, thanks to sva@sparc.spb.su (Vladimir Strigun).

M HistoryImpl.cpp
M NativeEventThread.cpp
M WindowControlActionEvents.cpp
M WindowControlImpl.cpp
M WrapperFactoryImpl.cpp
M ns_util.h

HistoryImpl.cpp NativeEventThread.cpp WindowControlActionEvents.cpp 
WindowControlImpl.cpp WrapperFactoryImpl.cpp ns_util.h
Comment 6 Ashu Kulkarni 2000-11-08 17:19:17 PST
r = ashuk

looks good.
Comment 7 edburns 2000-11-09 10:33:56 PST
Fix checked in.
Comment 8 edburns 2000-11-13 16:15:34 PST
Fix checked in.
Comment 9 Vladimir Strigun 2001-09-10 05:53:17 PDT
Mark this bug as verified.
Verifid with Mozilla/5.0 (Windows; U; WinNT4.0; en-US; rv:0.9.1) Gecko/20010910

Note You need to log in before you can comment on or make changes to this bug.