Use keyboard bindings to move around the dashboard file browser

RESOLVED DUPLICATE of bug 474064

Status

P3
normal
RESOLVED DUPLICATE of bug 474064
10 years ago
10 years ago

People

(Reporter: dion, Assigned: julian.viereck)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
up down left right. you know the drill.
(Reporter)

Updated

10 years ago
Priority: -- → P3
Whiteboard: dashboard
Target Milestone: -- → Future
Group: mozilla-corporation-confidential

Comment 1

10 years ago
Created attachment 367942 [details]
A proposed prototype for moving around the dashboard using the keyboard

Supports up/down/left/right/enter so far. Code is still a little messy, since I'm not sure what needs to be there and what doesn't, but I wanted to see if I was going in the right direction before I got too carried away. :)

A couple of known issues:
    * When scrolling up and down a list using up/down arrows, the list does not scroll (you can "fall" off the screen).
    * If there is nothing selected on the dashboard (path is empty), then the keyboard controls don't work.
This is a mass migration from Mozilla Labs :: Bespin to Bespin :: Dashboard.
Component: Bespin → Dashboard
Product: Mozilla Labs → Bespin
QA Contact: bespin → dashboard
Whiteboard: dashboard
(Assignee)

Comment 3

10 years ago
I think this was fixed in https://bugzilla.mozilla.org/show_bug.cgi?id=474064; so would s.o. please mark this bug as fixed?
Yeah, this does look like a duplicate of bug 474064. Which is weird, because it looks like they were both filed by Dion within a couple of days of each other.

Sorry your patch didn't get in, Evan.
Assignee: nobody → julian.viereck
Status: NEW → RESOLVED
Last Resolved: 10 years ago
OS: Mac OS X → All
Hardware: x86 → All
Resolution: --- → DUPLICATE
Target Milestone: Future → 0.2.0
Duplicate of bug: 474064
You need to log in before you can comment on or make changes to this bug.