Open Bug 474719 Opened 11 years ago Updated 8 years ago

add preview functionality (QuickLook-like) for attachments

Categories

(Thunderbird :: Mail Window Front End, defect)

defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: dmose, Unassigned)

References

()

Details

John mentioned a while ago that he found himself using the QuickLook stuff in Mail.app a lot and thought something similar could be a good fit for Thunderbird.  I think we should definitely consider this, although to me it feels too big to happen in a Tb3 timeframe. 

If a Mac hacker came along and wanted to just build on top of the QuickLook APIs, that would probably be notably less work while being at least a step in the right direction.
Awesome, now we'll have one with all one word "quicklook" in the summary when I search that way instead of two words ;)
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 457546
I'm not sure this should be a duplicate actually. While it's true using Quicklook would be awesome on Leopard, what about all the other platforms? For at least the most common attachment types (I'm guessing at pictures) it cannot be difficult to display a floating panel with the image in it. In fact I'm willing to bet it would be easier than integrating with Quicklook for real.
Agreed; these bugs imply different code and different strategies.  That said, I think the thing that's likely to be harder about this functionality for cross-platform use is getting the various format reading code written/embedded.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
OS: Mac OS X → All
Hardware: x86 → All
Duplicate of this bug: 515332
You need to log in before you can comment on or make changes to this bug.