If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XUL Tutorial: RDF example works from Apache, but not from local file.

RESOLVED DUPLICATE of bug 433014

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 433014
9 years ago
9 years ago

People

(Reporter: John Poole, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

at https://developer.mozilla.org/En/XUL_Tutorial/RDF_Datasources

There is a custom RDF file at http://developer.mozilla.org/samples/xultu/examples/animals.rdf

There is a custom XUL at http://developer.mozilla.org/samples/xultu/examples/ex_datasrc_2.xul
 which displays and references "animals.rdf" files.

To recreate:
Save locally the URLs above (xul - right click View link and SaveAs, RDF - right click RDF and SaveAS) in D:\Temp\xul_rdf_example. In Firefox 3.0.5, File-Open File "D:\Temp\xul_rdf_example\ex_datasrc_2.xul", the column headers display, but nothing appears for the data.   If the directory XulRDFExample is copied over to an Apache server and accessed via http, then the data appears.

I also tried modifying ex_datasrc_2.xul by saving as ex_datasrc_2_http_rdf.xul and making changes as follows:
   datasources="animals.rdf" 
to
 datasources="http://[INSERT YOUR APACHE URL HERE]/testing/xul/animals.rdf" 

and had the same result: column headings, no data.

I also tried modifying the datasource in ex_datasrc_2_fullpath.xul
changes as follows:
   datasources="animals.rdf" 
to
 datasources="file:///D:/Temp/xul_rdf_example/animals.rdf" 

Reproducible: Always

Steps to Reproduce:
1. Save locally in same directory: http://developer.mozilla.org/samples/xultu/examples/animals.rdf and http://developer.mozilla.org/samples/xultu/examples/ex_datasrc_2.xul
2. In Firefox, File-Open File ex_datasrc_2.xul

Actual Results:  
Only the columns appears, the RDF data does not display.  This only happens when trying to load the files locally.  When the files are served through Apache, then the data displays.

Expected Results:  
columns *AND* RDF data display

The ex_datasrc_2.xul should display column and data columns just as it does when called from http://developer.mozilla.org/samples/xultu/examples/ex_datasrc_2.xul
(Reporter)

Comment 1

9 years ago
On the theory that the RDF file is not being loaded because the file is not being perfectly pointed to, here are the variations I tried that did not meet with success:

datasources="animals.rdf"
datasources="file:///animals.rdf"
datasources="file:///D:/Temp/xul_rdf_example/animals.rdf" datasources="file:///D:\\Temp\\xul_rdf_example\\animals.rdf"

This test was on Windows XP, hence the forward/backslash variations.
Are you sending the appropriate content-type headers from your server?
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Misread your description, confirmed.
Component: Help Documentation → General
QA Contact: help.documentation → general

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 433014
You need to log in before you can comment on or make changes to this bug.