updating reloaded images in pragma-nocache pages.

VERIFIED DUPLICATE of bug 80011

Status

()

Core
ImageLib
P3
major
VERIFIED DUPLICATE of bug 80011
18 years ago
17 years ago

People

(Reporter: pnunn, Assigned: Stuart Parmenter)

Tracking

Trunk
mozilla0.9.1
All
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPME, URL)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
bug# 30852 for nsBeta3. (Bug#30852 was closed for nsbeta2).

updating reloaded images in pragma-nocache pages.

When the image is the top document as in the test url,
the image (a clock) is updated.

When the image is in an html page with a pragma-nocache,
the image is not updated. A simple test page will be attached.
It will access the same clock test url.

The cause has been found. A change in nsDocumentViewer.cpp (for bug#47095)
created the problem. It will be backed out. 

I'm creating this bug to make sure our case is tested.
(Reporter)

Comment 1

18 years ago
Created attachment 12325 [details]
simple test file with pragma-nocache meta tag
(Reporter)

Updated

18 years ago
Status: NEW → ASSIGNED
(Reporter)

Comment 2

18 years ago
hyatt has backed out his change in nsDocViewer.cpp which
fixes this bug.
-p
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Updated

17 years ago
QA Contact: elig → tpreston

Comment 3

17 years ago
This clock image does not update in Mac build 2001030608
or Win 2001030605 or linux 2001030608, therefore I am reopening it
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Reporter)

Updated

17 years ago
Target Milestone: --- → mozilla1.0
(Reporter)

Comment 4

17 years ago
All pnunn bugs reassigned to Pav, who is taking over
the imglib.
Assignee: pnunn → pavlov
Status: REOPENED → NEW
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → ---
(Assignee)

Comment 5

17 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 18 years ago17 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

17 years ago
ok, i lied.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Updated

17 years ago
Whiteboard: DUPME

Comment 7

17 years ago
another one in the category of not honoring cache preferences lined up to be
fixed in 0.9.1
Target Milestone: --- → mozilla0.9.1
(Assignee)

Comment 8

17 years ago
marking as a dup of 73450 since the fix in it fixes this problem.

*** This bug has been marked as a duplicate of 73450 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 9

17 years ago
hm, wrong bug
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 10

17 years ago
dup of 32269.

*** This bug has been marked as a duplicate of 32269 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 11

17 years ago
honestly, i'm going to dup this correctly.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Assignee)

Comment 12

17 years ago
i think this is the right one ;)

*** This bug has been marked as a duplicate of 80011 ***
Status: REOPENED → RESOLVED
Last Resolved: 17 years ago17 years ago
Resolution: --- → DUPLICATE

Comment 13

17 years ago
verified dups
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.