crashes [@ nsCSSFrameConstructor::FindInputData]

RESOLVED FIXED

Status

()

--
critical
RESOLVED FIXED
10 years ago
2 months ago

People

(Reporter: dbaron, Assigned: bzbarsky)

Tracking

({topcrash})

Trunk
topcrash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

So, the line we're crashing on corresponds perfectly to the crash that was fixed by http://hg.mozilla.org/mozilla-central/rev/9ac7c363cf78 which makes me think that this is in fact also the cause of bug 474915.
In particular, http://hg.mozilla.org/mozilla-central/rev/692ae2bf70de essentially backed out http://hg.mozilla.org/mozilla-central/rev/9ac7c363cf78 (although the previous time I don't know that it was known to show up in crash-stats).
(Assignee)

Updated

10 years ago
Blocks: 474961
(Assignee)

Updated

10 years ago
Blocks: 474915
(Assignee)

Comment 3

10 years ago
I restored the null-check.  http://hg.mozilla.org/mozilla-central/rev/915c70b15d1f
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Assignee)

Updated

10 years ago
Assignee: nobody → bzbarsky
(Assignee)

Comment 4

10 years ago
I filed bug 475015 to get some URLs for those crashing pages.  So far, the only one I found at http://crash-stats.mozilla.com/topcrasher/byurl/Firefox/3.2a1pre is http://www.daemon-search.com/explore and I just loaded it a few dozen times with no crash.  :(
Judging from bug 474915 and bug 474961, we may well have two of them in the talos pageset.
(Assignee)

Comment 6

10 years ago
Yeah, but I don't have that pageset...
I bet Alice does, though.
Duplicate of this bug: 475074
Crash Signature: [@ nsCSSFrameConstructor::FindInputData]

Updated

2 months ago
Product: Core → Core Graveyard
Component: Layout: Misc Code → Layout
Product: Core Graveyard → Core
You need to log in before you can comment on or make changes to this bug.