left and right arrow on tab bar doesn't make a 1-tab move anymore

VERIFIED FIXED in Firefox 3.6a1

Status

()

Firefox
Tabbed Browser
--
major
VERIFIED FIXED
10 years ago
8 years ago

People

(Reporter: Peter6, Assigned: Gavin)

Tracking

({regression, verified1.9.1})

3.5 Branch
Firefox 3.6a1
x86
Windows XP
regression, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +
in-litmus -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090123 Minefield/3.2a1pre ID:20090123033224

repro:
open more tabs than the length of the tab bar
click on the left/right arrow to move the tabs left or right

result:
it only moves a past of the tab-width

Comment 1

10 years ago
Are you sure this is a regression from bug 471499?
Flags: blocking-firefox3.1?
Version: Trunk → 3.1 Branch

Updated

10 years ago
Target Milestone: --- → Firefox 3.1b3
Maybe different, but clicking on a tab to enable the 'focus-ring' then trying to scroll tabs does nothing. 

This in the error consol2:
Error: element.getBoundingClientRect is not a function
Source file: chrome://global/content/bindings/scrollbox.xml
Line: 266
Setting the focus-ring and using left-right arrows WFM, but they seem to be following a MRU order, rather than a linear move left & right.
Blocks: 457651
No longer blocks: 471499
Was this fixed by the first patch in bug 474964 (landed 2009-01-23 16:48:05
PST)?
This is now WFM on latest hourly.

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2a1pre) Gecko/20090123 Minefield/3.2a1pre Firefox/3.0.4 ID:20090123232759
(Reporter)

Comment 8

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090124 Minefield/3.2a1pre ID:20090124024054

still totally broken.
I can't even acces the first tab without any additional tricks

Updated

10 years ago
Assignee: highmind63 → dao
Depends on: 474964
This is still broken, but will be fixed by dao's patch in bug 474964.
I can't reproduce this now that bug 474964 is fixed, but I'm not sure I could reproduce it before then... can anyone else confirm that this is fixed (on trunk and 1.9.1)?

Updated

10 years ago
Assignee: dao → gavin.sharp
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: fixed1.9.1
Resolution: --- → FIXED
Target Milestone: Firefox 3.1b3 → Firefox 3.2a1

Updated

10 years ago
Flags: blocking-firefox3.1?
(Reporter)

Comment 11

10 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090125 Minefield/3.2a1pre ID:20090125034316

VERIFIED
Verified on trunk and 1.9.1 with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090125
Shiretoko/3.1b3pre (.NET CLR 3.5.30729) ID:20090125052901

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090125
Minefield/3.2a1pre ID:20090125034316
Status: RESOLVED → VERIFIED
Flags: in-litmus?
Keywords: fixed1.9.1 → verified1.9.1

Updated

9 years ago
Flags: in-testsuite+
Flags: in-litmus? → in-litmus-
You need to log in before you can comment on or make changes to this bug.