Closed Bug 475048 Opened 13 years ago Closed 10 years ago

TM: Only emit alias check in for *PROP if the object's shape matches the global object's shape

Categories

(Core :: JavaScript Engine, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: gal, Assigned: gal)

Details

Attachments

(1 file)

*PROP guards on the shape of the object, and we know the global object's shape at recording time so only check for aliasing if the shapes match and aliasing is possible. This is a small perf with (ballpark 10ms).

The testcase incorrectly returns 3 if I disable the alias check. With the patch it still returns 9, which proves that the logic works.
Flags: wanted1.9.1?
Attached patch patchSplinter Review
Attachment #358434 - Flags: review?(brendan)
Attachment #358434 - Flags: review?(brendan) → review+
Comment on attachment 358434 [details] [diff] [review]
patch

Righteous!

/be
This should flow into 1.9.1, no question. Bake it first, but don't reject or forget it once baked.

/be
Pushed to TM. 

http://hg.mozilla.org/tracemonkey/rev/9fe03078c765
Whiteboard: fixed-in-tracemonkey
Status: NEW → ASSIGNED
Backed out due to potential tinderbox failure: http://hg.mozilla.org/tracemonkey/rev/05cbbc9f1ae2
Backed out again. This is confirmed as the source of the orange-ness of WINNT and occasionally also other platform's mochitests (symptom: browser hang/timeout).

http://hg.mozilla.org/tracemonkey/rev/dd55da1b9c81
Whiteboard: fixed-in-tracemonkey
Flags: wanted1.9.1? → wanted1.9.1-
These bugs are all part of a search I made for js bugs that are getting lost in transit:

http://tinyurl.com/jsDeadEndBugs

They all have a review+'ed, non-obsoleted patch and are not marked fixed-in-tracemonkey or checkin-needed but have not seen any activity in 300 days. Some of these got lost simply because the assignee/patch provider never requested a checkin, or just because they were forgotten about.
Obsolete with the removal of tracejit.

(Is the test worth checking in?)
Flags: in-testsuite?
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.