Closed Bug 47507 Opened 20 years ago Closed 19 years ago

Focus not set for input when opening Open Web Location dialog

Categories

(SeaMonkey :: UI Design, defect, P2)

x86
FreeBSD
defect

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 52268

People

(Reporter: jesper, Assigned: don)

Details

(Keywords: polish, Whiteboard: se-radar, [nsbeta3+])

When opening a new URL (ALT-L) you have to click in the input field to type
anything, this is not logic.
This is Event Handling, I think - either that, or the dialog needs to have some 
property (SetInitialFocus or some such) that it doesn't have.

-> Event Handling, CCing ben@netscape.com (loads of people seem to have had 
their fingers in openLocation.xul, but he's been doing the tweaking.)

Gerv
Status: UNCONFIRMED → NEW
Component: Keyboard Navigation → Event Handling
Ever confirmed: true
akkana/don/mcafee, any guess who should get this one?
Bug 35087 (saari), marked Future, covers the general problem that dialogs should
always set the focus; trudelle's suggested workaround is that each dialog
explicitly set focus upon opening, so I'll leave this bug with don since his
team would probably own the OpenURL dialog.  It's an accessibility issue, so it
would be nice if someone addressed it one way or the other.
I'll work on this.
Component: Event Handling → XP Apps: GUI Features
bug 51549 (similar to this) was recently fixed --any chance of getting this
fixed soon? blake, should this be assigned to you or law or someone else...?

adding se-radar to status so that i can find this bug more easily. pls don't
remove it [yet], thx.
Keywords: nsbeta3, polish
Summary: Focus not set for input when typing alt-L → Focus not set for input when opening Open Web Location dialog
Whiteboard: se-radar
Nav triage team: reassigning to Blake. Thanks, Blake! [nsbeta3+]
Priority: P3 → P2
Whiteboard: se-radar → se-radar, [nsbeta3+]
this is actually caused by bug 52268

*** This bug has been marked as a duplicate of 52268 ***
Status: NEW → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
will vrfy once bug 52268 is fixed...
This now seems to be working under Linux with build 2000092721.
yow, i thought i had marked this vrfy'd... doing so now.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.