If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Scrollbars on Vista lose the grippy on page scrolling

RESOLVED WORKSFORME

Status

()

Core
Widget: Win32
RESOLVED WORKSFORME
9 years ago
a year ago

People

(Reporter: mak, Unassigned)

Tracking

({regression})

Trunk
x86
Windows Vista
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
I see this issue on:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b3pre) Gecko/20090123 Shiretoko/3.1b3pre

i'm on a long bugzilla list of bugs, i scroll up or down with the mouse wheel or the keyboard up/down keys (does not happen if i drag it to a position). The grippy appears and disappears intermittently.
Notice this does not happen on short pages, seem to happen only when the scrollbar grippy is at minimum size.

i recorded a small video to show the issue:
http://www.bonardo.net/scrollbar/

I'm not sure this is the right component for scrollbars, but couldn't find a better one :\
If these are native-drawn scrollbars, then it's probably the native theme code, although not definitely.
Component: Layout → Widget: Win32
QA Contact: layout → win32
Or was this a recent regression?  If so, maybe more likely layout.
(Reporter)

Comment 3

9 years ago
it was working in 3.0.x, i should try to find a regression range
(Reporter)

Comment 4

9 years ago
works:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080917034815 Minefield/3.1b1pre
does not work:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b1pre) Gecko/20080918073230 Minefield/3.1b1pre

regwindow could be:
http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-09-17+03%3A48%3A15&enddate=2008-09-18+07%3A32%3A30
not sure I've seen this, but I've encountered page which wouldn't scroll using XP Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090621 Minefield/3.6a1pre (.NET CLR 3.5.30729)
20160502172042  Mozilla/5.0 (Windows NT 6.0; rv:46.0) Gecko/20100101 Firefox/46.0
20160509040557 	Mozilla/5.0 (Windows NT 6.0; rv:49.0) Gecko/20100101 Firefox/49.0


I tested on Windows Vista x86 with FF latest release 46.0 and latest Nightly 49.0 on a long bugzilla list of bugs and I can't reproduce the issue.
Please retest this on the latest Firefox version and see if you can reproduce the problem.
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.