No back/forward buttons in toolbar when using classic skin

VERIFIED DUPLICATE of bug 47081

Status

Core Graveyard
Skinability
P3
major
VERIFIED DUPLICATE of bug 47081
18 years ago
10 years ago

People

(Reporter: Alek Jeziorek, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({classic})

Trunk
x86
Windows 98
classic

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
-start browser
-edit|preferences
-go to the themes preference
-click on classic skin
-click on the switch themes button
-close browser
-restart browser and there won't be any back/forward buttons
Win32 m18 trunk build 2000-08-03-08-M18

Comment 1

18 years ago
Trunk only: This is bad. I see it too. Raising severity and nominating for 
nsbeta3. There is no way to get these buttons back (unless I delete this profile 
and start with a new one..prob). Also trying to switch back to the modern theme 
is not possible from the prefs UI. Is there a bug for this? cc:sairuh
Severity: normal → major
Keywords: nsbeta3
hm, a side-effect of bug 47081?

Comment 3

18 years ago
I don't see this problem (win98, same build - 80308 M18) or the one shrir 
mentions (about not being able to switch to the modern skin).

Comment 4

18 years ago
Nikhil please look into this.
Assignee: hangas → nbhatla
Keywords: classic

Comment 5

18 years ago
I don't think that this is skin-specific, but rather a general skin-switching 
bug.  After launching 2000080714-M18 Commercial in the classic skin, I opened up 
the themes-prefs panel and switched to modern.  Instantaneously after switching, 
the forward/back buttons disappeared in the modern skin.  After restarting 
Netscape, the buttons returned.  Switching back to classic caused no problems, 
and the buttons did not disappear when I quit and restarted the app.  Then when I 
switched to modern again, the back/forward buttons were gone.  This is on Win 98.

Comment 6

18 years ago
I am seeing this exact same behavior (missing buttons from modern) on my Mac as 
well.

Comment 7

18 years ago
this appear's to be a theme-switching bug, as described above.  Switching
component to Skinability.
Assignee: nbhatla → ben
Component: Themes → Skinability
QA Contact: paw → BlakeR1234

Comment 8

18 years ago
nav triage team:
works for me on pchen's mac tip build from 8/09
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
Builds :2000081008m18 all platforms
I am *definitely* still seeing this problem on all platforms using today's 
builds exactly as Alek has mentioned in his initial steps. Reopening.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 10

18 years ago
see this on all platforms using build 2000-08-10-08-M18
EXACT steps to reproduce:
-create a profile with any name (i.e lijvehblkjdb)
-start browser
-Edit|Preferences
-In the Appearance category click on themes
-switch the themes to classic then press ok
-after themes are switched press ok and...
-File|Quit
-Restart the browser using the same profile and the back and forward buttons 
will be missing
-this also mixes the modern with classic skin in some instances (modern lay out 
but classic buttons)
-preferences are totally useless as well and this is always reproducible
Note: this works with any profile, new or old, as long as it switched themes to 
classic then quited out of the browser

Comment 11

18 years ago
this is bug 47081. marking as a dup.

*** This bug has been marked as a duplicate of 47081 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

18 years ago
verifying
Status: RESOLVED → VERIFIED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.