Status

()

Firefox
General
RESOLVED WORKSFORME
9 years ago
9 years ago

People

(Reporter: Timothy Miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.5) Gecko/2008120121 Firefox/3.0.5

I have this page open:

http://www.newyorker.com/reporting/2008/06/30/080630fa_fact_gawande?currentPage=6

When I "save and quit", this page causes a popup to appear, preventing firefox from quitting.

Most gratifyingly, however, all the documents that are saved are in fact saved correctly.  When I restore the session, all of the documents are reopened correctly.  So the bug is only in quitting, not in the restoring.  It was, however, very worrying the first time it occurred.  I rely heavily on the "save and quit" functionality.

Reproducible: Always

Steps to Reproduce:
1.  Go to the URL I mentioned above
2.  Save and quit
3.  Find that you have to quit again.
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5

Can't reproduce this behavior. Can you give this a try in safe mode http://support.mozilla.com/en-US/kb/Safe+Mode and with a new profile http://support.mozilla.com/en-US/kb/Basic+Troubleshooting#Make_a_new_profile
(Reporter)

Comment 2

9 years ago
I tried creating a new profile, and I didn't experience the problem.

After updating to 3.0.6, I noticed that I didn't any longer get the "save and quit" dialog.  I searched around to find out that I could set in preferences to "Show my windows from last time."  That works, and it quits without this bug, but I also don't get the dialog anymore that asks if I want to quit or save and quit or cancel.  

How do I get that back in case I want it?  I might want to try reenabling that dialog to find out if that is connected with the problem.
(Reporter)

Comment 3

9 years ago
Ok, I figured out how to get that dialog back.  Quitting works fine without that popup appearing now.

There needs to be a general Firefox bug about "weird stuff happens whenever you install an update."
When you set the pref to "Show my windows from last time", that essentially overrides the dialog pref. If you want to be asked whether or not to restore the windows and tabs, you have to 1) have a different setting for that pref and 2) have more than one tab open 3) make sure that you're quitting the application so that you don't run in to bug 354894. I'm going to resolve this as worksforme because this works with a clean profile. Please reopen if you can reproduce the initial bug on a clean profile.

->WORKSFORME
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.