Closed Bug 475311 Opened 11 years ago Closed 11 years ago

frequent "Use of getPropertyCSSValue() is deprecated" warnings when opening/switching windows

Categories

(Core :: CSS Parsing and Computation, defect, P3)

x86
macOS
defect

Tracking

()

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: mossop, Unassigned)

References

Details

(Keywords: regression)

Attachments

(1 file)

Having the error console log this much whenever you open it is quite inconvenient. I note other windows (view source, DOM inspector) also log the message multiple times:

Warning: Use of getPropertyCSSValue() is deprecated.  To upgrade your code, use getPropertyValue() instead.
Source File: chrome://global/content/console.xul
Line: 0
Hmm. Where exactly do we use this in the Error Console?
http://mxr.mozilla.org/mozilla-central/search?string=getPropertyCSSValue(
From the fact that multiple windows log it I'd expect it to be some core code that they all use
Oh, it's probably nsMenuItemIconX::GetIconURI (although there are a few other C++ callers).  I guess I should just back out the warning.
Yeah, it's nsMenuItemIconX::GetIconURI. I thought about switching it to use GetPropertyValue before I found this bug, but it checks the type as well. This is making my console nearly unusable, since I get hundreds of these on startup.
Summary: Opening the error console logs messages about use of deprecated messages → frequent "Use of getPropertyCSSValue() is deprecated" warnings when opening/switching windows
-> Layout: Style, I guess, since at the very least Cocoa needs some non-warning way to get this info, but yeah, I'd appreciate a backout!
Component: Error Console → Style System (CSS)
Product: Toolkit → Core
QA Contact: error.console → style-system
Since a few days the error console of Thunderbird 3.1a1pre is crowded to overflowing with this warning.
I see:

Warning: Use of getPropertyCSSValue() is deprecated.  To upgrade your code, use getPropertyValue() instead.
Source File: chrome://messenger/content/hiddenWindow.xul
Line: 0

and 

Warning: Use of getPropertyCSSValue() is deprecated.  To upgrade your code, use getPropertyValue() instead.
Source File: chrome://messenger/content/messenger.xul
Line: 0

I don't see this in Shredder/3.0b2pre, the TB 3.1a1pre build is my own, because there are no TB 3.1a1pre nightlys for OS X at the moment.

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090202 Thunderbird/3.1a1pre
> Created an attachment (id=360090) [details]
> Same warning in Thunderbird 3.1a1pre

Thanks but we already know the cause, and if you are going to put the errors in an attachment, copy and paste the text; there is no need to do a screenshot.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090203 Minefield/3.2a1pre

The same msg comes up in the Error Console (twice, in fact) whenever I right-click in a page's content area to bring up the context menu.

I was just about to file it as a new Bug, but found this one first.
Should this Bug's title be changed to include my finding (and 'XP' added to the affected Platforms), or should I go ahead and file a new Bug?
No, don't file a new bug.

I'm planning to back the warning out the next time the tree is open and I have time to watch it.
Fixed by backout:
http://hg.mozilla.org/mozilla-central/rev/674246a64ed2
http://hg.mozilla.org/mozilla-central/rev/e2a26d16bf06
Status: NEW → RESOLVED
Closed: 11 years ago
Priority: -- → P3
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
You need to log in before you can comment on or make changes to this bug.