"Selected Folder" Option on a Search in the Library is Broken

VERIFIED FIXED in Firefox 3.6a1

Status

()

defect
VERIFIED FIXED
11 years ago
10 years ago

People

(Reporter: aakashd, Assigned: adw)

Tracking

({verified1.9.1})

Trunk
Firefox 3.6a1
x86
Windows XP
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

Reporter

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090123 Shiretoko/3.1b3pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090123 Shiretoko/3.1b3pre

On any search within a folder in bookmarks, the "Selected Folder" option is highlighted by default, but the search results in all bookmarks saved on the profile, associated with the search term, to be shown in the contents pane. There's no point in having the default "Selected Folder" option be highlighted if that's the case. Also, if the "Selected Folder" option is clicked on again, the content pane is emptied out.

Reproducible: Always

Steps to Reproduce:
1. Open the Bookmarks Library
2. Select the Bookmarks Toolbar and create two new bookmarks named "New Bookmark".
3. Type in "new" into the search bar on the top right side of the library.
Actual Results:  
The "Selected Folder" Option is highlighted, but the search results show all bookmarks with the term "new" the contents pane. Also, clicking on the "Selected Folder" option again results in all results removed from the contents pane.

Expected Results:  
Only the two new created bookmarks should be found in the contents pane anytime the "Selected Folder" option is highlighted or clicked on again.
Component: Bookmarks & History → Places
Product: Firefox → Toolkit
QA Contact: bookmarks → places
Version: unspecified → 1.9.1 Branch
the component was correct instead, "Firefox/Bookmarks & History" since this is about the Library/UI.
Component: Places → Bookmarks & History
Product: Toolkit → Firefox
QA Contact: places → bookmarks
Version: 1.9.1 Branch → 3.1 Branch
Reporter

Comment 2

11 years ago
(In reply to comment #1)
> the component was correct instead, "Firefox/Bookmarks & History" since this is
> about the Library/UI.

I just re-ran the STR and found that the search does work on the bookmark toolbar. I mistakenly realized that it was bringing up the results in the RSS feed as well (my bookmarks toolbar includes Google Maps, YouTube, Wikipedia and the News feed folder). Yet, after clicking on "Selected Folder" again does empty out the search results in the contents pane. So, please disregard the first comment in the bug as its not broken, but focus on the mouse-click event on "Selected Folders" section.
Assignee

Comment 3

10 years ago
I can confirm comment 2 on

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090202 Minefield/3.2a1pre

To clarify, STR:
1. Open the Bookmarks Library
2. Select a folder (e.g., Bookmarks Toolbar) in the left pane
3. Type a string into the Library's search box that matches a name of a bookmark in the folder
4. Click "Selected Folder"

Actual Results:  
The matching bookmark(s) appears in the content pane after searching, but when "Selected Folder" is clicked, the content pane becomes empty

Expected Results:
Clicking "Selected Folder" should not clear the content pane
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assignee

Comment 4

10 years ago
Hmm, looks like this is only a problem in the root folders, i.e., bookmarks toolbar, bookmarks menu, and unsorted bookmarks.  Works as expected in subfolders.
Assignee

Updated

10 years ago
Assignee: nobody → adw
Assignee

Comment 5

10 years ago
Posted patch v1Splinter Review
getConcreteItemId.  That was easy.
Attachment #363224 - Flags: review?(mak77)
Assignee

Updated

10 years ago
Blocks: 469437
Attachment #363224 - Flags: review?(mak77) → review+
Keywords: checkin-needed
http://hg.mozilla.org/mozilla-central/rev/6acd3f95d07e
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.2a1
Version: 3.1 Branch → Trunk
Comment on attachment 363224 [details] [diff] [review]
v1

asking approval for regression
Attachment #363224 - Flags: approval1.9.1?
Comment on attachment 363224 [details] [diff] [review]
v1

a191=beltzner
Attachment #363224 - Flags: approval1.9.1? → approval1.9.1+

Comment 10

10 years ago
Still not working for me.

Windows xp
Build 20090331041754
locale en-US
verified with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090415 Shiretoko/3.5b4pre

Once you've searched you have to select the folder to search in in "Search:"
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.