Closed Bug 475504 Opened 12 years ago Closed 12 years ago

inconsistient behaviour of language pack activation

Categories

(Toolkit :: Add-ons Manager, enhancement)

enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 377881

People

(Reporter: sandro.boehler, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; de; rv:1.9.0.5) Gecko/2008120122 Firefox/3.0.5
Build Identifier: 20081209

Activating additional language packs does not have any effect.

Instead, for using the language packs, each link has to be added a parameter UILocale (or additional add-ons have to be installed) - which appears like a workaround for an existing bug (had a discussion with several people, not anybody disagreeing).

Proposition:
- as is already: one can install new lang packs
- as is already: lang packs can be activated and deactivated
- new: at the same time, only one pack can be activated - is another one selected, the previous one is automatically deactivated
- new: activating a lang pack sets automatically the corresponding language (if needed, after restart)
- new: deactivating the active lang pack switches back to the default language

Same for Firefox.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Langpacks are handled by the add-ons manager as far as I know, therefore moving to the right component.
Component: General → Add-ons Manager
Product: Thunderbird → Toolkit
QA Contact: general → add-ons.manager
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 377881
You need to log in before you can comment on or make changes to this bug.