Attachment should be checked on actuality when sending

RESOLVED DUPLICATE of bug 378046

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 378046
10 years ago
9 years ago

People

(Reporter: Hendrik Maryns, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
1. Compose a message with an attachment.
2. Save the message (I am unsure whether this occurs both on local disk or with IMAP)
3. close TB
4. edit the attached file
5. restart TB
6. open the message from the drafts, maybe edit it, send it

Result: the first version of the attachment is sent, NOT the revised version.

Expected: TB should check the modification time of the attachment on disk (if it is there, since, obviously, when using IMAP, the file might not be there, in which case you would simply take the version from the server) and if the file on disk is newer, use that.

Comment 1

9 years ago
Are you sure that this is the expected/desired behavior?

There are a couple of bugs where the current behavior that Thunderbird merely holds an internal reference to the file added as attachment (or, as a special case, an image inserted into the message body) until the message is sent or saved as a draft causes problems. The expectation in those reports was that an actual snapshot of the current content is taken and added to the message, thus regardless of what happens afterwards, that content is preserved (also see my remark in bug 404922 comment #6 and the related pointers off this bug).

What you are asking for is contrary to that intuition, thus Thunderbird would be supposed to keep track of any changes performed after the data was attached.

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 378046
You need to log in before you can comment on or make changes to this bug.