Closed Bug 475538 Opened 14 years ago Closed 14 years ago

Remove obsolete files in intl/uconv

Categories

(Core :: Internationalization, defect)

defect
Not set
normal

Tracking

()

RESOLVED FIXED

People

(Reporter: smontagu, Assigned: smontagu)

Details

Attachments

(1 file, 1 obsolete file)

The following files in intl/uconv can be removed:

ucvibm/cp1046.uf, cp1046.ut -- conversion tables for IBM1046 encoding, which was removed in bug 413613

ucvlatin/8859-11.ut, tis620.ut -- these were replaced by cp874.ut in bug 127755.

ucvlatin/macukrai.ut, macukrai.uf, nsUnicodeToMacUkrainian.* nsMacUkrainianToUnicode.* -- MacUkrainian is identical with MacCyrillic, see http://www.unicode.org/Public/MAPPINGS/VENDORS/APPLE/UKRAINE.TXT
Attached patch Patch (obsolete) — Splinter Review
Attachment #359049 - Flags: review?(VYV03354)
Is MacUkrainian still requird in charset menu whilst it's exactly the same as MacCyrillic?
(In reply to comment #2)
> Is MacUkrainian still requird in charset menu whilst it's exactly the same as
> MacCyrillic?

We're in string freeze right now, so can we handle that in a follow-up bug?
(In reply to comment #3)
> We're in string freeze right now, so can we handle that in a follow-up bug?
Are you planning to land this on the branch?
If you aren't, string freeze is not an issue because l10n has a 1.9.1 branch.
For example, bug 474655 was landed only on the trunk. Am I missing something?
OK, but I still want to make a separate bug for changing the charset menu. Because the menu is in a localizable file (toolkit/locales/en-US/chrome/global/intl.properties), localizations will have to include the patch, so it will be easier to have a separate bug with only that change.

Also, if we are already going to change all localizations, I think that we could actually remove all the Mac- charsets from the menus. I had a reviewed patch to do this some years ago in bug 203838, but never checked it in because it caused a regression that I didn't understand. I now know how to prevent that.
Attachment #359049 - Attachment is obsolete: true
Attachment #360679 - Flags: review?(VYV03354)
Attachment #359049 - Flags: review?(VYV03354)
Comment on attachment 360679 [details] [diff] [review]
Updated patch including removing unused lines from charsetData.properties

OK, let's separate this bug from a localizable part.
Attachment #360679 - Flags: review?(VYV03354) → review+
http://hg.mozilla.org/mozilla-central/rev/29f5a8085435
Status: NEW → RESOLVED
Closed: 14 years ago
Flags: in-testsuite-
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.