Fire an event when bookmarks are restored

VERIFIED DUPLICATE of bug 470314

Status

()

Firefox
Bookmarks & History
P2
normal
VERIFIED DUPLICATE of bug 470314
9 years ago
9 years ago

People

(Reporter: thunder, Unassigned)

Tracking

Trunk
Firefox 3.5
Points:
---
Bug Flags:
wanted-firefox3.5 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [weave])

(Reporter)

Description

9 years ago
When bookmarks are restored, it makes Weave sync delete records for every item, and new records for the restored bookmarks.  Since the Weave server doesn't currently expunge deleted records (and we'd rather not do that often), then users just get more and more rows, with most items deleted.

So,

I'd like to get an event when the user restores bookmarks.  In that case I'll actually do a server wipe and do a fresh sync.
Whiteboard: [weave]
Priority: -- → P2
Whiteboard: [weave] → [weave][good first bug]
Flags: wanted-firefox3.1+
Target Milestone: --- → Firefox 3.1
is this much different from bug 470314?
(Reporter)

Comment 2

9 years ago
No, I'd forgotten I'd filed that one.  Closing as a dupe!
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 470314

Updated

9 years ago
Status: RESOLVED → VERIFIED
Whiteboard: [weave][good first bug] → [weave]
Target Milestone: Firefox 3.1 → Firefox 3.5
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.