Assertion when minimizing after 'New Navigator Window'

VERIFIED WORKSFORME

Status

()

Core
Layout
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: servaas goossens, Assigned: clayton)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Minimizing a navigator window immediately after choosing
New Navigator Window, but before the new window appears (!),
results in:
###!!!ASSERTION: SetBounds Size < 0: 'aRect.width >= 0 && aRect.height >= 0',
file d:\builds\seamonkey\mozilla\layout\xul\base\src\nsBox.cpp, line 511.

Comment 1

18 years ago
Does not happend on Linux 2000080308.
WORKSFORME on 20000820 WinNT4. sgoossens@ortec.nl - what build were you using, 
and do you still see this problem in recent builds?

Gerv
(Reporter)

Comment 3

18 years ago
I was using M16 when I reported the bug.
I can still reproduce it with M17 (2000080712, is that recent enough?).
A correction to the reported behaviour: you must minimize
the *newly created* window (not the original one) before its
paint routine (of whatever that is called) gets any chance of
replacing the pixels of the original window by its own contents.
So I still see the original window's contents when pressing the
minimize button on the new one.

The new window should start with displaying my home page. This is
a simple html page with 3 frames, some javascript and a couple of
tables. When I change my homepage location to about:blank, the problem 
doesn't seem to occur. Maybe I should send you my homepage...

Comment 4

18 years ago
please attach the html for your page.  Thanks :)

Comment 5

18 years ago
Tomer/Gerv: be aware that you need to be using a debug build to see assertions.

Comment 6

18 years ago
temporarily marking wfm (cause it does on win2k in a debug build pulled 
yesterday)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 7

17 years ago
Works For Me:
OS: Windows 98
Platform: PC
Mozilla Build #: 2000100508
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.