Eliminate the need to have a second argument to Hook.process when inside a BLOCK

RESOLVED WONTFIX

Status

()

Bugzilla
Extensions
--
enhancement
RESOLVED WONTFIX
10 years ago
4 years ago

People

(Reporter: Alex Eiser, Unassigned)

Tracking

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_5_5; en-us) AppleWebKit/528.6+ (KHTML, like Gecko) Version/3.2.1 Safari/525.27.1
Build Identifier: HEAD

If you use an extension, and want to add content via a HOOK

in template/en/default/list/list.html.tmpl
[% PROCESS bugcount %]

[% BLOCK bugcount %]
  [% Hook.process('ALEX_ASKING') %]
[% END %]


Reproducible: Always

Actual Results:  
this tries to find the following template files in 3 locations
./extensions/example/template/en//-ALEX_ASKING..tmpl
./extensions/example/template/en/default/hook/bugcount/ALEX_ASKING/*.tmpl
./template/en/default/hook/bugcount/ALEX_ASKING/*.tmpl


Expected Results:  
Instead of 
./extensions/example/template/en//testalex1-ALEX_ASKING..tmpl
OR
./extensions/example/template/en/list/testalex1-ALEX_ASKING..tmpl

The following two are ok.
./extensions/example/template/en/default/hook/testalex1/ALEX_ASKING/*.tmpl
./template/en/default/hook/testalex1/ALEX_ASKING/*.tmpl

If this is expected behavior for backwards compatibility then please bug as invalid.

This is a variant of bug 318205
(Reporter)

Comment 1

10 years ago
> Expected Results:  
> Instead of 
> ./extensions/example/template/en//testalex1-ALEX_ASKING..tmpl
> OR
> ./extensions/example/template/en/list/testalex1-ALEX_ASKING..tmpl

should have been

Expected Results:  
Instead of 
./extensions/example/template/en//bugcount-ALEX_ASKING..tmpl
Should be
./extensions/example/template/en/list/bugcount-ALEX_ASKING..tmpl

Also note that these two
./extensions/example/template/en/default/hook/testalex1/ALEX_ASKING/*.tmpl
./template/en/default/hook/testalex1/ALEX_ASKING/*.tmpl
Don't respect a disabled flag

Updated

10 years ago
Whiteboard: DUPME

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Whiteboard: DUPME
Duplicate of bug: 318205
(Reporter)

Comment 3

10 years ago
note that the above issues still exists on the head. Reopen 318205 if you think they are a duplicate.

Comment 4

10 years ago
mkanat says you run 3.1.2. If that's true, could you upgrade to 3.2 and tell us if you can still reproduce the problem? If yes, then reopen the bug.
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> mkanat says you run 3.1.2. If that's true, could you upgrade to 3.2 and tell us
> if you can still reproduce the problem? If yes, then reopen the bug.

I tested this on bugzilla head.

It may not be a real problem, but the actual paths that are checked are bad.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 6

10 years ago
Let's confirm it for now.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Mac OS X → All
Hardware: x86 → All
Version: unspecified → 3.3.1

Updated

9 years ago
Component: Bugzilla-General → Extensions

Updated

9 years ago
Assignee: general → extensions

Comment 7

9 years ago
This bug, as reported, is actually invalid, though because of a reason you might not expect--we solved the problem you're experiencing by allowing a second argument to Hook.process, which you're not specifying in your hook call.

However, I think there's a way to work around that ourselves and not require people to have a second argument to process() when they call it from inside a block.
Summary: Extensions: the path to the hook is incorrect when called from inside a block → Eliminate the need to have a second argument to Hook.process when inside a BLOCK
Target Milestone: --- → Bugzilla 3.6

Updated

9 years ago
Severity: normal → enhancement
Target Milestone: Bugzilla 3.6 → ---
mkanat says this bug is fixable but doesn't explain how. Until he comes back and tells us, marking WONTFIX :-)

Gerv
Status: NEW → RESOLVED
Last Resolved: 10 years ago4 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.