Closed Bug 475773 Opened 12 years ago Closed 12 years ago

Paypal buttons will not load until page is refreshed

Categories

(Core :: DOM: Core & HTML, defect)

x86
Windows Vista
defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: cstaley416, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.6) Gecko/2009011913 Firefox/3.0.6

The paypal "ADD TO CART" buttons under ORDER ARTWORK show up as straight lines until I hit the refresh button. This has been happening in the last few versions of Firefox. (This problem doesn't exist in Chrome, Explorer, Opera and other browsers.)

Reproducible: Always

Steps to Reproduce:
1.Go to the web page in Firefox.
2.
3.
Actual Results:  
The paypal "ADD TO CART" buttons under ORDER ARTWORK show up as straight lines until I hit the refresh button. 

Expected Results:  
One should see the buttons.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090128 Minefield/3.2a1pre

Can you retest with the latest trunk nightly build, for I believe this is fixed now: http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/latest-mozilla-central/
Version: unspecified → 3.0 Branch
Thanks for the tip. All of my artwork and the Paypal buttons now load with Minefield. Hope this update will be included in the next version of Firefox.
I checked the branche and it's not yet there. When I have time I'll try to find out what bug is responsible for the fix on trunk.
Component: General → DOM
Product: Firefox → Core
QA Contact: general → general
Version: 3.0 Branch → 1.9.1 Branch
Is this a regression from something?
I don't know. I check from time to time if the patch is already on the branch then I can close it.
Whiteboard: [need fix range]
I still don't see the patch on branch.
Range: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=602e6c8d494a&tochange=39dc85bc5d99
The only one can be Bug 347174 and it has a flag.
Given that this isn't a regression I doubt we'll try to port the feature it's relying on to the branch. So either we should keep this a 1.9.1 bug and move it to tech evangelism, or we change the version to trunk and mark it WFM or FIXED.
PROBLEM SOLVED

My website was provided by Windows Live. I added Paypal buttons by pasting the code into the HTML box provided. Just recently Microsoft added a Paypal location for pasting the code and now the buttons work perfectly in Firefox after making all the changes.
Great you found a workaround. :)
Marking WFM.
Whiteboard: [need fix range]
Version: 1.9.1 Branch → Trunk
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WORKSFORME
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.