Tag Column Sort does not take into account blank tags

RESOLVED WONTFIX

Status

()

RESOLVED WONTFIX
10 years ago
10 years ago

People

(Reporter: aakashd, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090126 Minefield/3.2a1pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090126 Minefield/3.2a1pre

Clicking on the Tag Column Header results in a Name Column Sort if all Tag fields are empty.

Reproducible: Always

Steps to Reproduce:
1. Go to Bookmarks | Organize Bookmarks
2. Select "Bookmarks Menu" on the library hierarchy pane on the left side of the window.
3. Click on the Tag column header 3 times and view the result each time.
Actual Results:  
Tag column is sorted by name

Expected Results:  
Tag column should not be sorted if there are no tags present.
Component: General → Bookmarks & History
QA Contact: general → bookmarks
Version: unspecified → Trunk
that's normal, if elements have not tags we fallback to title sorting
this has an edge case, if the user has no tags but still asks to sort by tags (WHY?) he will be surprised from seeing bookmarks sorted by title...

still i can't see an efficient way to detect if there's no item tagged in the current results. So i suggest wontfix due to edge case.
Whiteboard: WONTFIX?

Comment 3

10 years ago
Another way to look at it:  The primary sort for tags is tags, and the secondary sort is bookmark title.  If two bookmarks have the same tags, they will be sorted relative to each other by their titles.  If no bookmarks are tagged, that's a special case of all bookmarks having the same tags -- specifically, no tags.  So, the sort will end up being by title.

Seems like a wontfix to me, too.
WONTFIX per comments #1-3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Whiteboard: WONTFIX?
You need to log in before you can comment on or make changes to this bug.