Last Comment Bug 475834 - /**/ comments with newlines in them do not act as line breaks
: /**/ comments with newlines in them do not act as line breaks
Status: VERIFIED FIXED
fixed-in-tracemonkey
: verified1.9.1
Product: Core
Classification: Components
Component: JavaScript Engine (show other bugs)
: Trunk
: All All
: -- normal (vote)
: mozilla1.9.2a1
Assigned To: Blake Kaplan (:mrbkap) (please use needinfo!)
:
Mentors:
: 397104 475884 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-01-28 15:47 PST by Brendan Eich [:brendan]
Modified: 2011-01-30 12:45 PST (History)
5 users (show)
sayrer: wanted1.9.1+
bob: in‑testsuite+
bob: in‑litmus-
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
js shell testcase (243 bytes, text/plain)
2009-01-28 15:56 PST, Brendan Eich [:brendan]
no flags Details
web page testcase (314 bytes, text/html)
2009-01-28 15:56 PST, Brendan Eich [:brendan]
no flags Details
So, comme ça? (1.32 KB, patch)
2009-01-28 16:11 PST, Blake Kaplan (:mrbkap) (please use needinfo!)
no flags Details | Diff | Review
Better [Checkin: Comment 8 & 9] (1.25 KB, patch)
2009-01-28 23:21 PST, Blake Kaplan (:mrbkap) (please use needinfo!)
brendan: review+
Details | Diff | Review

Description Brendan Eich [:brendan] 2009-01-28 15:47:16 PST
This matters in automatic semicolon insertion in ES3. Doug Crockford pointed this out and said only Opera follows the spec. We should make the fix, as I doubt it will break anyone and it is easy -- and anyway the spec is better than the bug.

/be
Comment 1 Brendan Eich [:brendan] 2009-01-28 15:56:27 PST
Created attachment 359405 [details]
js shell testcase
Comment 2 Brendan Eich [:brendan] 2009-01-28 15:56:52 PST
Created attachment 359407 [details]
web page testcase
Comment 3 Blake Kaplan (:mrbkap) (please use needinfo!) 2009-01-28 16:11:13 PST
Created attachment 359410 [details] [diff] [review]
So, comme ça?

This was the most obvious way to do it.
Comment 4 Blake Kaplan (:mrbkap) (please use needinfo!) 2009-01-28 23:21:30 PST
Created attachment 359481 [details] [diff] [review]
Better
[Checkin: Comment 8 & 9]
Comment 5 Simon Bünzli 2009-01-28 23:49:54 PST
*** Bug 475884 has been marked as a duplicate of this bug. ***
Comment 6 Brendan Eich [:brendan] 2009-01-29 11:24:49 PST
Safe ride-along for 3.1, gets us right with jslint and other analyzers.

/be
Comment 7 Brendan Eich [:brendan] 2009-01-29 11:25:33 PST
Comment on attachment 359481 [details] [diff] [review]
Better
[Checkin: Comment 8 & 9]

Shouldn't need much baking -- pls. get it into tm and m-c asap.

/be
Comment 8 Blake Kaplan (:mrbkap) (please use needinfo!) 2009-01-29 12:23:57 PST
http://hg.mozilla.org/tracemonkey/rev/b224b8b053ff
Comment 10 Brendan Eich [:brendan] 2009-02-10 19:08:00 PST
This seems well-baked for 1.9.1.

/be
Comment 11 Serge Gautherie (:sgautherie) 2009-02-14 11:26:21 PST
Needs approval1.9.1 before checkin-needed.
Comment 14 Bob Clary [:bc:] 2009-02-26 11:04:19 PST
v 1.9.1, 1.9.1-tm, 1.9.2
Comment 15 Brendan Eich [:brendan] 2011-01-30 12:45:46 PST
*** Bug 397104 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.