Calendar entries for time zone and event start/stop times not sticking

VERIFIED FIXED

Status

quality.mozilla.org
Website
P1
critical
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: marcia, Assigned: paulc)

Tracking

Details

When I set a time for my event in QMO, it seems when I go back into the entry the time that I set does not stick.

STR:
1. Create an event.
2. Set the time zone to Los Angeles
3. Set a start time of 9 AM
4. Set a stop time of 6 PM
5. Go back into the event and the time has reset to time zone NY with default times of 12 AM and 12 PM.

Updated

9 years ago
Assignee: nobody → cbook
Status: NEW → ASSIGNED
Raising severity as this is causing confusion with the time scheduled for our meetup as well as test event on Friday.
Severity: normal → major
Mass move of bugs to new product
Component: quality.mozilla.org → QMO: Website
Product: Websites → QMO
(Assignee)

Comment 3

9 years ago
Carsten, I can look into this in about a week.
marking this a p1, we need to fix this
Severity: major → critical
Priority: -- → P1
(Assignee)

Comment 5

9 years ago
So I just tested this and got the times both be 12AM and 12AM (same), but the timezone was saved as LA. In any case, it's a bug, I think I can take it, but I will need a QMO db dump to work on this locally. (emailed Carsten about this)
Assignee: cbook → paul.craciunoiu
(Assignee)

Updated

8 years ago
Target Milestone: --- → 1.0
(Assignee)

Updated

8 years ago
Depends on: 502783
(Assignee)

Comment 6

8 years ago
This too has been fixed, without code change but with the removal and addition of the date fields. They weren't holding time, only date... Very bad.

The fix will require re-inputting the date/time on first-time editing for currently existing events, but that shouldn't be a problem. Future events will be created properly.
(Assignee)

Comment 7

8 years ago
This was because events dates were dates only, and the time wasn't being saved properly. Now it's saved on both stage and prod. Once we push, the times will show up the same on view/edit page. Right now they show up different because of a bug in the event template (not a bug in the modules) with timezone conversion.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

8 years ago
View:
http://quality.mozilla.org/events/2009/jul/15/learning-about-mozilla-crash-reporting-and-analysis
Edit:
http://quality.mozilla.org/node/454/edit
it's looking great for the events listed on QMO currently.
Status: RESOLVED → VERIFIED
Target Milestone: 2.0 → ---
You need to log in before you can comment on or make changes to this bug.