Internet Archive Flash videos won't play with Flashblock installed

RESOLVED WORKSFORME

Status

()

Core
Plug-ins
RESOLVED WORKSFORME
9 years ago
8 years ago

People

(Reporter: Smokey Ardisson (offline for a while; not following bugs - do not email), Assigned: Philip Chee)

Tracking

({regression})

Trunk
regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

STR:

1) Install Fx3.1b2, a recent Fx3.0.7pre, or Camino 2.0b2pre and Flashblock 1.5.7.1
2) Visit http://www.archive.org/details/Univac_Commercial_Classic_Old_Vintage
3) Click on the site's "click-to-play" image
4) Click on Flashblock's "click-to-play" div

ER: Flash video plays
AR: Black flash of something, then Flashblock's "click-to-play" div reappears. Rinse, repeat.

I see this behavior in Fx3.1b2 (which was from before m-c and m-1.9.1 branched, I think), a Firefox 3.0.7pre build from the other day and a recent Camino 2.0b2pre nightly (both 1.9.0.x), with Flashblock 1.5.7/1.5.7.1 (they are equivalent).

The video appears as expected after step 4 in Camino 1.6.7pre (1.8.1.21pre) with the same version of Flashblock, so it seems to be a Gecko regression somewhere between 1.8.1 and 1.9.0; I haven't had the chance to do more hunting yet, though the Camino user who first reported this said he thought these videos worked not too long ago.
Flags: blocking1.9.0.6?
Johnny, can you look at this regression ASAP? Talking with Dan, this blocks Firefox 3.0.6, which has already gone to beta users...
Flags: blocking1.9.0.6? → blocking1.9.0.6+
Assignee: nobody → jst
Also: Philip, is there anything you can do on Flashblock's side of things to fix this? Any help debugging the issue would be greatly appreciated.
This should block 1.9.1 as well. I'm guessing (and I'll confirm) that it's a regression from bug 438830.
Flags: blocking1.9.1?
I tested this in 3.0.5 and can reproduce the issue there. Not sure this still blocks 1.9.0.6... I need to find a regression range. Dan?
Flags: blocking1.9.0.6+ → blocking1.9.0.6?
We should get a regression range on this. Is it a change to the Internet Archive or a change on our end?
Keywords: regressionwindow-wanted

Comment 6

9 years ago
FWIW, on one of my machines, I have Fx 3.04 + FlashBlock 1.5.6 and I see the same problem.
Seems to work in Firefox 2. My guess is that this broke due to us fixing bug 1156. Trev, mind having a look to see if this is something that should be dealt with in Flashblock rather than in the browser?
Yeah, sorry for the quick trigger on this guys. I assumed it was a recent regression.
(In reply to comment #7)
> Seems to work in Firefox 2. My guess is that this broke due to us fixing bug
> 1156.

Unfortunately, I see the same broken behavior in 

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a1) Gecko/20050921 Firefox/1.6a1

which should be the last build before bug 1156 landed.
Flags: blocking1.9.0.6?
Oh, and Dan confirmed this on Windows as well.
OS: Mac OS X → All
(Assignee)

Comment 11

9 years ago
/me scratches head. If the flashblock placeholder reappears, that means our XBL is rebound to the flash object. We use an expando property to prevent Flashblock going into an infinite loop. We've had recent problems with expando properties due to changes in XPCNativeWrappers but those changes were much more recent. Someone could run this in a debugger to see what the javascript is doing.

Comment 12

9 years ago
Johnny, I tried to check whether bug 1156 is responsible for this - but it doesn't look like it, removing the type attribute along with the other plugin attributes doesn't change anything. However, when I check with the JavaScript Deobfuscator extension what JavaScript code gets executed on that page when I click the Flashblock placeholder - the webpage receives that click and handles it by reinserting the embed. Apparently, Flashblock isn't stopping event propagation. This change fixes the issue:

--- flashblock.xml      Thu Jan 29 08:12:27 2009
+++ flashblock.xml      Thu Jan 29 08:11:06 2009
@@ -54,7 +54,8 @@
 }

 // Show the original animation
-function flashblockShowFlash() {
+function flashblockShowFlash(event) {
+       event.stopPropagation();
        if(placeholder.flashblock == "frame") {
                current.height = current.prevHeight;
                current.width = current.prevWidth;

I am only unsure why this issue only popped up now.
(Assignee)

Comment 13

9 years ago
Thanks trev!
(In reply to comment #12)
> I am only unsure why this issue only popped up now.

My guess (now) is that the Internet Archive changed the way they do videos and that the site change "caused" this issue, not Flashblock itself.

Philip, I'm going to assign this to you but feel free to assign to someone else on the Flashblock team and resolve it as INVALID (not Mozilla's bug) when a new Flashblock gets released.
Assignee: jst → philip.chee
Flags: blocking1.9.1?
(Assignee)

Comment 15

9 years ago
Sure, no problem.
Blocks: 476038
(Assignee)

Comment 16

9 years ago
I have just pushed out Flashblock 1.5.8 which includes a fix for this bug.

<http://flashblock.mozdev.org/installation1.html>
<http://downloads.mozdev.org/flashblock/flashblock-1.5.8.xpi>

I shall be pushing this to AMO Real Soon Now. Resolving as WORKSFORME, but really there should be a "FIXED UPSTREAM" resolution.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → WORKSFORME
Philip, thanks for updating Flashblock. It's greatly appreciated.
Keywords: regressionwindow-wanted
You need to log in before you can comment on or make changes to this bug.