download .exe files on windows - no download progress

VERIFIED DUPLICATE of bug 44176

Status

SeaMonkey
General
P3
normal
VERIFIED DUPLICATE of bug 44176
18 years ago
14 years ago

People

(Reporter: german, Assigned: Bill Law)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Steps:
Go to http://www.betanews.com
click on any of the download links there.
The dialog whether to open/execute the downloaded file shows up, but 
is 'frozen', while the download progresses as indicated in the progressmeter on 
the status bar, once download is finished, it asked for user to choose file 
name.
Expected behavior:
After the save or execute directly dialog shows up the user shold get to pick a 
file name. The save or execute dialog should close and the download progress 
dialog shold appear.
(Reporter)

Comment 1

18 years ago
On further investigation it seems the save or execute dialog is not quite 
frozen, the cancel button can be pressed but it does *not* result in cancelling 
the download which happily continues
this really sounds like a dup of bug 44176, the more i think of it...

*** This bug has been marked as a duplicate of 44176 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 3

18 years ago
Sarah, I think there are subtle, yet useful distinctions between this bug and 
bug 44176.

That bug seems (after I waded through all the discussion) to now be about the 
fact that there's no (standalone) progress dialog corresponding to the 
downloading.  If you think differently, please correct me.

This bug talks about the Downloading dialog being "frozen" or perhaps that the 
file picker doesn't appear until the download completes.

Each of these problems has existed at some point in the not-too-distant past.  I 
have observed this dialog being effectively inoperative, but only on WinNT using 
my debug build (and often times downloading from the very same machine, which 
could exacerbate things).  Previously, I observed this dialog coming up "empty" 
(a window frame with no content); remaining empty until the actual download to 
the temporary file had completed.  I remember coming by your cube one day to 
demonstrate that "feature," BTW.

But that was a temporary thing, I think.

There was a point in time, if I recall correctly, where the file picker did not 
appear until the download was completed.  I believe that that issue has been 
resolved.

So my question:  Is anybody still seeing instances of the Downloading dialog 
appearing empty or inoperative and remaining that way until the downloading has 
completed?

If that problem persists, then I might suggest that we track it using this bug. 
 If not, then this one should really be closed as WFM (since it isn't really a 
dup of a bug that talks about some other dialog being missing).  But given that 
it is already "closed," in effect, the fact that it was closed differently is 
hardly worth worrying about (i.e., not a "[nsbeta3+] caliber" problem).

The big issue is whether we can still reproduce the "frozen" Downloading dialog.

Comment 4

18 years ago
the site is giving me mysql errors,I tried getting the installer.exe from the
latest dir on mozilla, and got a working dl box (2000091408)

Comment 5

18 years ago
Has anyone got anything else to say on this bug?
Seeing that bug 44176 is fixed, and if no one can see any incidents of this bug
again then suggest it is either verified as a duplicate or marked WFM and
verified as such.
vrfying since the problem itself seems to be gone no matter if it's a dup of the
mentioned bug or not.

reopening to close as worksforme seems to me to be a waste of bugmail.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.