Table cells ignore css background properties on <TD>&nbsp;</TD>

VERIFIED DUPLICATE of bug 41959

Status

()

Core
Layout: Tables
P3
major
VERIFIED DUPLICATE of bug 41959
18 years ago
18 years ago

People

(Reporter: Matthias Kerkhoff, Assigned: karnaze (gone))

Tracking

({css1, testcase})

Trunk
x86
Windows NT
css1, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/4.74 [en] (WinNT; U)
BuildID:    2000080322

If a table cell contains only a non-breaking-space (&nbsp;) then css-background 
styles on this cell won't be drawn.

Reproducible: Always
Steps to Reproduce:
1. Load the testcase


Actual Results:  2. You won't see a red background on the first cell in table #1
3. You won't see a red background on the first cell in table #2, which also has 
empty-cells set.
4. You will see a red background on the second cell, which contains an 'A'							

Expected Results:  All cells should have a red background. This bug must be 
introduced with one of the last builds, it worked fine before.

This may be very important, because it could completly break sites which use 
tables + css for layout purposes.
(Reporter)

Updated

18 years ago
Keywords: css1, testcase
(Reporter)

Comment 1

18 years ago
Created attachment 12361 [details]
testcase
(Reporter)

Updated

18 years ago
Keywords: nsbeta3
(Reporter)

Comment 2

18 years ago
Could someone please verify this one ? It already has a simple testcase and may 
be an important one...
Summary: Table cell backgrounds not drawn on some cells → Table cells ignore css background properties on <TD>&nbsp;</TD>

Comment 3

18 years ago
i confirm. it breaks lots of page designed with tables (wether it's a good
design practice or not).

using the 2000-08-04-21-M18 Linux build.

Comment 4

18 years ago
I think this is dupe of bug 41959. Matthias could you check this and close the 
bug if it is the case.
(Reporter)

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 41959 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
verify
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.