If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Need an API to clear all "login saving enabled" entries

RESOLVED DUPLICATE of bug 1058438

Status

()

Toolkit
Password Manager
--
enhancement
RESOLVED DUPLICATE of bug 1058438
9 years ago
a year ago

People

(Reporter: Dolske, Unassigned)

Tracking

({polish})

Trunk
polish
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
+++ This bug was initially created as a clone of Bug #474792 +++

Currently one can clear all entries with:

var hosts = pwmgr.getAllDisabledHosts()
for each (var host in hosts)
    pwmgr.setLoginSavingEnabled(host, true);

But this is a tad undesireable...

* It's not obvious that setting it |true| removes any record of the entry (which is what CRH wants)
* It's inefficient if there are lots of saved exceptions
(Reporter)

Updated

9 years ago
No longer depends on: 474792
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1058438
You need to log in before you can comment on or make changes to this bug.