AMO tests cross the streams

RESOLVED FIXED in 5.0.3

Status

addons.mozilla.org Graveyard
Admin/Editor Tools
--
major
RESOLVED FIXED
9 years ago
2 years ago

People

(Reporter: clouserw, Assigned: jbalogh)

Tracking

unspecified
5.0.3

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
I mentioned this in bug 475994 but noticed it in another bug as well.  Running the tests is using real data.  That's not good at all.
[x] adding proper background music.
(Reporter)

Updated

9 years ago
Target Milestone: 5.0.2 → 5.0.3
(Assignee)

Comment 2

9 years ago
Created attachment 365062 [details] [diff] [review]
make sure we're using the test db during testing
Attachment #365062 - Flags: review?(clouserw)
(Reporter)

Updated

9 years ago
Attachment #365062 - Flags: review?(clouserw) → review+
(Reporter)

Comment 3

9 years ago
Comment on attachment 365062 [details] [diff] [review]
make sure we're using the test db during testing

This is going to help a lot.  If our tests aren't using test data the chances of them passing are slim. :)
(Assignee)

Comment 4

9 years ago
r22837
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Keywords: push-needed
(Reporter)

Comment 5

9 years ago
QA: If you want to verify this:

This URL has 3 failing tests right now:

https://preview.addons.mozilla.org/en-US/firefox/tests?case=controllers%2Fcomponents%2Fimage.test.php

Once this lands it won't.
(In reply to comment #5)
> QA: If you want to verify this:
> 
> This URL has 3 failing tests right now:
> 
> https://preview.addons.mozilla.org/en-US/firefox/tests?case=controllers%2Fcomponents%2Fimage.test.php
> 
> Once this lands it won't.

That URL's not loading anything for me :-(
(Reporter)

Updated

9 years ago
Keywords: push-needed
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.