Thunderbird growl notification tells me I have 23075744 new mails

RESOLVED WONTFIX

Status

MailNews Core
Backend
RESOLVED WONTFIX
9 years ago
5 years ago

People

(Reporter: mossop, Unassigned)

Tracking

Trunk
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

9 years ago
Created attachment 359828 [details]
screenshot

Apparently the dock icon couldn't hold the full count but the growl notification gave it to me. Needless to say not a single new mail could be found in my mail folders.
(Reporter)

Comment 1

9 years ago
Created attachment 359832 [details]
screenshot t
(Reporter)

Comment 2

9 years ago
It seems to keep wanting to tell me about these mails.

Updated

9 years ago
Summary: Thunderbird tells me I have 23075744 new mails → Thunderbird growl notification tells me I have 23075744 new mails
Clearly the fix here is to unCC yourself from some bugs, you're getting to much bugmail, Dave ;)

What kind of account (server) is this happening with?  It almost sounds like an unsigned int wrapping around, but I can't locate an obvious spot in the code.  This code is in flux this week as I try to get a couple of big patches in, but I'd be interested to get more info so I can fix this, since I can't reproduce here.
Component: General → Backend
Product: Thunderbird → MailNews Core
QA Contact: general → backend
(Reporter)

Comment 4

9 years ago
Since the first day it has stopped showing me this message so regularly, however it does occasionally tell me there are a few new mails (up to 10 I think I've seen) randomly when there aren't.

This is using an IMAP connection to Mozilla's mail server (Zimbra).
I've seen this, too (I posted a screenshot of the dock icon on IRC yesterday).  I have several accounts set up, but Mozilla's Zimbra was one of them.  I see this very rarely, but I do see it every month or two and have seen it at least for several months, so I don't think it's something new.
I wonder if there is something about how we are interacting with your Zimbra server at the IMAP level?  This may be totally unrelated, but it's interesting that you two are seeing this.  I can't reproduce it (which means nothing, I realize) and I don't have access to this server.
My dock icon said 1900010x (couldn't read the last digit).  Neither that nor the one Mossop got is anywhere near a place where a signed int would roll over, no matter how many bits you use for it.  So a signed int rolling over doesn't seem likely.
No, it's not that, I checked the code.  I was just thinking out loud.

Updated

7 years ago
Duplicate of this bug: 595714

Comment 10

5 years ago
Sorry, Growl support has been removed from the current versions.

Mass bug change. Please reopen if you disagree.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 792793
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.